NO add-on!

Hi, I installed Homeassistent on a docker-compose file. but I don’t have add-on in the setting tab.

Because container does not include add-ons

Reference :

You’re managing your own containers…

1 Like

Yeah I checked this document, but I couldn’t find a way to add Node-red and ESP-Home

I’ve tried different ways to install Home Assistant on my MacOs, but it seems like none of them can’t support add-ons. So, is there any way to have it?

Addons in a docker system are not really addons, but are installed the same way you installed HomeAssistant; they are just other dockers you’ll need to compose (and configure) :wink:

1 Like

Even docker (“Home Assistant Container”) is not supported on MacOS.
If you want addons, your only (supported) option is using HAOS through a VM.

1 Like

I run HA container in Docker for Mac and it works very well (I prefer Docker to HAOS).

You absolutely can install both Node red and ESPHome in Docker and configure them to work with HA container (although I don’t use them myself).

Ignoring the whole container v HAOS argument, there are 2 specific restrictions to be aware of when using Docker for Mac (that do not exist for Docker for Debian on a RPi):

  1. No USB passthrough
  2. No network_mode: host (mDNS).

This is because Docker for Mac is actually a VM in itself. I’m pretty sure these restrictions will not effect NodeRed, but am not sure about ESPHome.

That’s likely why it’s not officially supported.
Besides mDNS, no host networking also means that nothing broadcast-related will work, so basically no auto-discovery.


Yeah, I’ve tried to add MQTT and Node-Red to my docker-compose file. I was able to get MQTT but not Node-Red!!! and have no idea abour ESP-Home

So I have an Ubuntu on UTM in my MacOs. I tried the docker on the Ubuntu.
The problem is VirtualBox does not work on MacOs with M1 chip. So this solution unfortunately does not work for me! Thanks for the help though.

Yeah I know! this line should be replaced by -p 8123:8123
Then it works.
So do you have any documentation about the way you’re running HA in a Docker container for Mac???!!

You can also use it without docker (through python command line)
used to do it like that (on W10 though)

cd c:\workshop\esphome

pip install esphome
pip install esphomeflasher
pip install --upgrade git+

esphome mideahvac.yaml wizard
esphome mideahvac.yaml compile

and then use an espflasher for the compiled bins :grin:

esphomeflasher (using the compiled C:\_workshop\esphome\mideahvac\.pioenvs\mideahvac\firmware.bin)
1 Like

what kind of documentation are you looking for?
I installed docker for Mac, used a docker-compose file and it works.

1 Like

Thanks, I’ll give it a try. Really appreciated the fast response! I was really frustrated, when I started this conversation, but now I can see the team is too damn supportive!!!
That’s perfect.

Would you be able to cat your docker-compose.yaml and share it? I want to compare to the one that I have on my end. I would be appreciated .

no problem. Here it is:

name: "smarthome"
    container_name: homeassistant
      - 8123:8123
      - ~/docker/containers/homeassistant:/config
      - TZ=Europe/London
    restart: unless-stopped
    privileged: true

1 Like

Thanks a million.

No worries - is yours much different?

1 Like

Don’t, it might take some time every now and then, but most people are here to seek and / or provide support…
And amongst the 174864 users, for sure there is someone to help out :grin:

But, please do try to search before you post :wink:
Remember we are all volunteers who try to help out.


No, almost the same. But now I know my file is correct

version: ‘3’
container_name: homeassistant
image: “
- /home/test/Homeassist:/config
- /etc/localtime:/etc/localtime:ro
restart: unless-stopped
privileged: true
- “8123:8123”

1 Like