No Audio From FFmpeg RTSP Stream

Hi, I have an RTSP stream that has both video and audio. I added the RTSP as a camera entity and used platform: FFmpeg since FFmpeg can stream both video and audio however I’m only getting video, no audio. Here is my code:

  - platform: ffmpeg
    name: Cam1
    input: -rtsp_transport tcp -i rtsp://admin:[email protected]:554/h264Preview_01_sub    

I also tried

input: rtsp://admin:[email protected]:554/h264Preview_01_sub

but still no audio.
I also tried converting an RTMP stream using VLC to RTSP and it works perfectly in any device that has VLC on my network accessing the new RTSP with audio and video, but not in HA.

Any help is greatly appreciated.

My understanding is that HA works as a Proxy, talking to the camera (rtsp in this case) on one side of the Proxy, and sending the camera’s media to the WebBrowser on the otherside of the Proxy. The Proxy may have to transform media from the camera to something the Browser understands. It is my understanding that for now only video is handled by the Proxy and not audio.

Did you get any further with this @alexmanny?

I followed this, which suggests the audio stream should work fine but it’s not working for me.