No bootable Medium, HAOS Fujitsu S920

I would like to install HAOS on a Fujitsu S920.
I have written the image to a mSATA hard drive. When I connect the mSATA via USB adapter to the Fujitsu everything runs normally. If I try to install the mSATA direct in the Fujitsu, then no boot media is found.

I have set the BIOS according to the instructions and also added the entry in efibootmgr.

Any ideas to solve my problem?

I have been struggling with the same problem on the same system (S920) for two days and haven’t found a solution yet. When I install HAOS on a USB and boot from it, it works perfectly. However, flashing to mSATA and booting from it gives me the same error.

I flashed the USB using Balena Etcher on Windows.
For flashing HAOS to mSATA I used another USB with XUbuntu plugged into my S920 and used Balena Etcher the same way I did it on Windows to flash the HAOS image to mSATA. This gave me the “no bootable device” error.

I even tried to flash using the dd command, but without success.

Looks like the only way, for now, is to run HAOS from a USB, which is not ideal considering the S920 has a drive built in but I don’t know what else to do as well.

I found a solution! You have to disable secure boot and CSM in BIOS. After this, your boot entry should show in the boot menu and you should be able to boot into HAOS.

Hope this helps.

1 Like

Hi, thanks for your reply.
I have also tried that, but unfortunately it did not work for me.

Can you show me your exactly UEFI Setup?

These are the BIOS settings I use to sucessfully boot into HAOS. Boot option #1 [HAOS] is the name of boot entry I created.

Hope this helps you.

Thank you for your efforts. Fortunately I have solved the problem. It was due to the wrong code in the installation instructions on the Home assistant page.
There is a “” too many.
Correct code is: efibootmgr --create --disk /dev/<drivename> --part 1 --label "HAOS" --loader '\EFI\BOOT\bootx64.efi'

I hope this helps someone


Nice, I am glad you solved it.

I’m brand spanking new to this game!
Do you care to do a short complete write up, on how to get HA running on a Fujitsu S920?

And another thing, is a S920 the way to go, when it has to live under the stairs in my appartment, with no monitor connection - so it has to be resolved remotely via another computer!?

Perform the activities here: Generic x86-64 - Home Assistant

Then go to this location: Generic x86-64 - Home Assistant and perform these activities.
NAMELY: Boot into your Live Ubuntu Desktop in UEFI mode and run those commands at the CLI (Command Line Interface)

Things you will need to do “sudo fdisk -l” to list all your drives (and note which one is your mSATA)
Make sure you “sudo” the efibootmgr or it will give you a “permission denied” error

I struggled with the same challenge but could resolve it with your comments! THANKS!

I am running into similar issue on S920:
I was running HAOS for few months or so without any issues, but yesterday I removed the msata device and inserted a different one to try different installations. No changes were done in bios (apart selecting bootable devices), just debian installation into new msata, and no changes were done on the old msata.

In the end I decided to go back to previous installation (the old non modified msata drive), but S920 no longer finds that msata as bootable (in boot options only Diagnostics program is listed). Secure boot is disabled as it was before. In SATA devices it is listed as inserted (SATA1 slot, the one under the cooler). If inserted in the other SATA slot it does not see drive at all.
CSM configuration was enabled, but even disabling it - it changes nothing.

What could have gone wrong? How to make it bootable without loosing data?

P.S. Is the second msata slot on S920 active at all? As it does not even see at all if msata drive is inserted.

Basically I needed to set back HAOS efi boot entry from any live linux instance running on that machine as my debian installation changed it:

efibootmgr --create --disk /dev/<drivename> --part 1 --label "HAOS" \
   --loader '\EFI\BOOT\bootx64.efi'

More details about that : Generic x86-64 - Home Assistant

1 Like