No devices found in HA by LocalTuya

Hi, I know this topic has been covered hundreds of times and I have read hundreds of threads on it but am still having no luck.

I am trying to setup local tuya and have my local keys etc that I need but when I try to add an integration for local tuya, there are no devices found and if I try the manual option to enter everything, the device cannot be found.

I am running HA on a dedicated machine running HA OS. That machine is connected to my network via LAN of 10.10.20.x while all of the existing devices (49 of them) are under a VLAN of 10.10.30.x.

I suspect the issue is the lan to vlan comms but am not sure what port if any to open or where to look to check. It has been 11 hours of trying to resolve the issue and I am now to confused and brain fried.

Network hardware is:
Ubiquiti Dream Machine Pro
LAN connection to dual WAN interfaces (in fallover config)
LAN connection to dedicated HA machine (Lenovo i7 Thinkcentre PC)
Tuya devices on WIFI thanks to 2 Ubiquiti AP’s

Can anyone advise me on where to start to find the fix?

PS - I do have Tuya linked to Google Home so I still have some control but have removed Tuya from HA. I also tried removing Tuya from HA and ensuring that the app was closed on my phone but still no luck.




Welcome! Have a :beer: to cool your :brain::upside_down_face:

Most Tuya systems require to be able to scan on all networks where you have Tuya devices on UDP ports 6666 and 6667.

TinyTuya (Tuya device scanner) [1.3.1]

Scanning on UDP ports 6666 and 6667 for devices (15 retries)...

I believe you need the Regular Tuya integration set up for those devices first.
The devices need to have internet access also.
Looks like you already know the app needs to be closed, but that doesn’t prevent them from being discovered.
Make sure auto discovery is turned on in the configuration.
If you know the IP address of the devices you can set them up manually.
As a side note, once you have those set up locally, you can kill the internet access for those devices. You just need the internet access until that device is set up in Local Tuya.

I too have the exact same issue, Im running a Dream machine and unifi AP’s etc

1 Like

Hello, did anybody come up with a stinky answer using this hardware setup? Thanks!

this is also the exact same issue for myself.
Has this been figured out?

I’ve got the same issue - all devices are listed in tuya, can see them in tuya cloud/api. Setup local tuya to talk to the API, but still returning me zero devices.

Does having Tuya setup in Home assist impact tuya local?

I just configure them manually. I have a spreadsheet with device id, local key, max, and static IP.

Then I just cut and paste.

Downside of ui based configuration.

Same issue here. Anyway we can help to move this along?

Same here , is anyone managed to fix it?

Same, would be happy to help troubleshoot.

Same here on RPI, anyone cracked it yet please? Also can’t identify tuya local IP on my router, and can’t find MAC address of Tuya devices.

1 Like

Then that might be your first problem.
I have no problems identifying them, getting their IP and MAC and also route their traffic.

I thought it might had to do with my devices being on a different subnet as HA but masquerading the traffic is not helping.

I have no problem getting the devices to work with the normal Tuya integration. It’s just the localtuya that’s not working for me.

1 Like

Hello guys,
I also have separated VLANs.
Tuya devices are broadcasting on the network. These broadcasts packets need to reach the other VLAN.
I have seen IGMP packets to
and UDP packets on on port 6667.
You need to forward these packets (very depending on your router and features. I have a Fortigate).
With these packets brocasted to the home-assistant IP (or VLAN), my new devices get discovered:

So, it is possible.


1 Like

Help! I have two HA servers running–one production and one development (I’m migrating to a new NUC). Dev is on the same network ( as Prod (; no VLANS in my world. However, I can only see a few devices in dev:

As compared to Prod:
(the above represents about 40% of the total devices)

I get the error Connection to device succeeded but no datapoints found, please try again. Create a new issue and include debug logs if problem persists. when I try to add manually with IP/ID/Key.

Noteworthy: I setup the Dev server from a full backup of the Prod server, so I’m at a total loss here. Hope someone knows something I don’t! Thanks in advance.

You may have a look at my post here.
I managed to connect to a device that was providing me such kind of error.
Maybe you did something on the prod server that you don’t remember.


I know this is an old post but it seems most relevant. I too am having trouble discovering devices on a separate VLAN. I use a Unifi USG Pro 4 and created a firewall rule to allow UDP traffic on 6666 and 6667 between all local addresses.

The rule seems to work because running tinytuya on a device on the 192.168.99.x network sees the Tuya devices on my IoT VLAN (192.168.20.x). I’ve tried reloading the localtuya configuration in HA and restarting HA, but afterwards still no devices found.

Has anyone using Unifi found a good rule to allow traffic on 6666 and 6667 that will make localtuya work across VLANs? I’ve found lots of posts about this issue but no solutions for a USG Pro 4 or any Unifi device for that matter.

1 Like