No devices found with tasmota beta

Tags: #<Tag:0x00007fc40ae59928> #<Tag:0x00007fc40ae597c0>

Hi all,

I was excited about the new Tasmota integration, but I’m having no luck.

My setup:

  • hass 0.118.3 (also tried 0.118.0 and 0.117.x) core
  • installed in a virtualenv on a Raspberry Pi, running homeassistant for years
  • mosquitto 1.5.7 installed from Raspbian repos, also working well for years
  • ACL configured to allow world read/write to tasmota/discovery
  • Firewall disabled

I’m using one of these Aoyocr switches. I’m using a fresh installation of tasmota 9.1.0 configured with that template (though also tried without) and SetOption19 0. No other changes other than connecting to my network.

I can use the device through its http interface, it is working.

When I add the tasmota integration it succeeds… then nothing happens. No new devices in unused entities, nothing seems to be found.

I don’t see any errors in the homeassistant or mosquitto log.

I’ve tried restarting the tasmota device and the Pi multiple times.

What am I missing?

Relevant links:

Did you mean SetOption19 1 to enable autodiscovery on Home Assistant?

Please see the first link for the docs.

Tasmota devices configured for native discovery ( SetOption19 0

Sorry, I use so19 on to push discovery each time my devices reset and I see them on HA.

I was just able to get one of my devices to show up in Tasmota beta. I am running 0.118.4 and all of my tasmota devices were running 8.2.0. I could not get the device to appear until I upgraded the device to 9.1.0 and used SetOption19 0 to disable MQTT discovery and enable HA discovery as it states in the first Warning on the doc https://tasmota.github.io/docs/Home-Assistant/#tasmota-integration-beta

Still no luck here with 0.118.5 and SetOption19 0.

When I add the integration, it asks me for the discovery topic prefix – I’m leaving the default of tasmota/discovery. Did you change anything here?

Are you using the built-in MQTT server or mosquitto?

No, I did not change the discovery topic and I am using Mosquitto that is in HASS Supervisor.

What firmware version are you running on your tasmota devices? I couldnt get mine recognized until I bumped to 9.1.0.

9.1.0, as I noted in the OP.

I’ve spent like 3 days and can’t get anywhere. Was excited to try this out, but I’ve made zero progress. Think I’ll just go back to ESPHome.

Try one more thing. Do a SetOption19 1 to turn on MQTT and then do another SetOption19 0. I had to do this on a plug just last night to get the plug to be recognized. Here’s the output in my console when I do this.

Also, at one point I was getting errors about not being able to connect to my MQTT broker. It turned out that I had an invalid user / pass on the MQTT tab. As soon as I corrected that, discovery worked,

15:04:27 CMD: SetOption19 1
15:04:27 MQT: stat/christmas-tree/RESULT = {"SetOption19":"ON"}
15:04:29 MQT: homeassistant/switch/5ACF82_RL_1/config = {"name":"Christmas Tree","stat_t":"tele/christmas-tree/STATE","avty_t":"tele/christmas-tree/LWT","pl_avail":"Online","pl_not_avail":"Offline","cmd_t":"cmnd/christmas-tree/POWER","val_tpl":"{{value_json.POWER}}","pl_off":"OFF","pl_on":"ON","uniq_id":"5ACF82_RL_1","dev":{"ids":["5ACF82"]}} (retained)
15:04:29 MQT: homeassistant/sensor/5ACF82_status/config = {"name":"Christmas Tree status","stat_t":"tele/christmas-tree/HASS_STATE","avty_t":"tele/christmas-tree/LWT","pl_avail":"Online","pl_not_avail":"Offline","json_attr_t":"tele/christmas-tree/HASS_STATE","unit_of_meas":"%","val_tpl":"{{value_json['RSSI']}}","ic":"mdi:information-outline","uniq_id":"5ACF82_status","dev":{"ids":["5ACF82"],"name":"Christmas Tree","mdl":"AUKEY SH-PA1","sw":"9.1.0(tasmota)","mf":"Tasmota"}} (retained)
15:04:32 MQT: tele/christmas-tree/STATE = {"Time":"2020-12-09T15:04:32","Uptime":"0T12:08:01","UptimeSec":43681,"Heap":25,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":19,"MqttCount":1,"POWER":"ON","Wifi":{"AP":1,"SSId":"***","BSSId":"***","Channel":11,"RSSI":62,"Signal":-69,"LinkCount":1,"Downtime":"0T00:00:04"}}
15:04:32 MQT: tele/christmas-tree/HASS_STATE = {"Version":"9.1.0(tasmota)","BuildDateTime":"2020-11-07T11:57:45","Module or Template":"AUKEY SH-PA1","RestartReason":"Power On","Uptime":"0T12:08:01","Hostname":"christmas-tree-3970","IPAddress":"***","RSSI":"62","Signal (dBm)":"-69","WiFi LinkCount":1,"WiFi Downtime":"0T00:00:04","MqttCount":1,"LoadAvg":19}
15:04:32 MQT: stat/christmas-tree/RESULT = {"Version":"9.1.0(tasmota)","BuildDateTime":"2020-11-07T11:57:45","Module or Template":"AUKEY SH-PA1","RestartReason":"Power On","Uptime":"0T12:08:01","Hostname":"christmas-tree-3970","IPAddress":"***","RSSI":"62","Signal (dBm)":"-69","WiFi LinkCount":1,"WiFi Downtime":"0T00:00:04","MqttCount":1,"LoadAvg":19}
15:04:38 CMD: SetOption19 0
15:04:38 MQT: stat/christmas-tree/RESULT = {"SetOption19":"OFF"}
15:04:39 LOG: Home Assistant MQTT Discovery disabled.
15:04:41 MQT: tele/christmas-tree/STATE = {"Time":"2020-12-09T15:04:41","Uptime":"0T12:08:10","UptimeSec":43690,"Heap":25,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":19,"MqttCount":1,"POWER":"ON","Wifi":{"AP":1,"SSId":"***","BSSId":"***","Channel":11,"RSSI":62,"Signal":-69,"LinkCount":1,"Downtime":"0T00:00:04"}}
15:04:41 MQT: stat/christmas-tree/RESULT = {"Time":"2020-12-09T15:04:41","Uptime":"0T12:08:10","UptimeSec":43690,"Heap":25,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":19,"MqttCount":1,"POWER":"ON","Wifi":{"AP":1,"SSId":"***","BSSId":"***","Channel":11,"RSSI":62,"Signal":-69,"LinkCount":1,"Downtime":"0T00:00:04"}}

@tpc77 – many thanks for your response.

I tried toggling SetOption19 1 -> SetOption19 0 a few times with no luck.

Can you walk me through your Tasmota setup from the beginning? I think your invalid user / pass might be a clue – I hoped that this would essentially “figure everything out” in the way that ESPHome does.

What I am doing:

  1. Upgrade to 9.1.0
  2. Reset all settings / blank slate
  3. Add my switch’s template so the button works
  4. SetOption19 0
  5. Get frustrated that nothing is happening

Do I need to manually configure Tasmota’s MQTT settings with my Home Assistant address? I was hoping it would automatically find the device like ESPHome does.

I think tasmota needs to know your mqtt settings. ESPhome needs to know them too when you use ESPhome with mqtt.

Okay, got it. Thanks for pointing me in the right direction.

This integration is not like ESPHome, which seems to just magically work.

Steps I had to take:

  1. Upgrade to 9.1.0
  2. Reset all settings / blank slate
  3. Add my switch’s template so the button works
  4. Disable all security settings from mosquitto (comment out acl_file, password_file, and allow_anonymous false)
  5. Go into Tasmota MQTT settings and add my server and port
  6. SetOption19 0
  7. Device now shows up in homeassistant/config/integrations under the Tasmota card
  8. Celebrate a little

Now for figuring out the proper ACL and security settings, I’ll probably write up this process and post back here.

Thanks again to all for the help.

ESPhome needs to know them too when you use ESPhome with mqtt.

Correct, but not when you use the native API; I misunderstood / misread and thought this updates was going to be using something similar for Tasmota, which would have been really exciting. Instead it looks like much of the burden of security and MQTT configuration is still up to the user.

1 Like

All working now, after a fair bit of fiddling with ACLs. Writeup: https://n8henrie.com/2020/12/setting-up-tasmota-beta-integration-with-home-assistant/

image

Has anyone see this? When I click on Tasmota, it disipears. Check the logs and get

Logger: homeassistant.setup
Source: setup.py:118
First occurred: 10:53:18 PM (7 occurrences)
Last logged: 10:59:56 PM

Unable to set up dependencies of tasmota. Setup failed for dependencies: mqtt

Ive installed the MQTT under supervisor. Very confused, what should I be looking for?

I had the same issue,
restarting HA helped for this issue,
still I have some other issues now

Thanks for that,

It just seemed to come good after a couple of restarts :slight_smile: