No devices or entites

Ok so after a few days of struggling and trying to figure out where I’m going wrong, I’m throwing in the towel and asking for help.

I have home assistant os installed on a pi, and am trying to set up mqtt to interface with a valetudo vacuum. Nothing I do seems to get it to auto discover.

Mosquito MQTT broker is set up as shown:

A user has been created in home assistant using the above credentials. If I delete these credentials from here, I get an error, so I assume it’s correct to leave them here?

Any ideas where I’m going wrong here? Or is there anything else I need to configure? Any help is appreciated!!

Edit: apologies for multiple posts, I couldn’t share the images in one post due to new user limits.

MQTT integration is showing “no devices or entites”:

MQTT is configured this way:

And if I listen to the topic, I can see the messages coming through:

This is your problem:


By default valetudo (and everything else I know of) uses homeassistant as the discovery topic with no prefix.


So unless you have a specific reason for using that discovery topic prefix change it to homeassistant delete it and restart your mqtt broker and Home Assistant.

If you are using that discovery topic prefix for some sonoff devices you will need to change them to use homeassistant as a discovery topic without a prefix for discovery.

BTW my screenshot is from a free program called “MQTT Explorer”. I recommend you download it to easily see your discovery topics and what is going on,

EDIT: actually that setting is not the discovery topic, just a discovery prefix. Delete it instead of changing it.

1 Like

Can’t believe how much I overcomplicated that… Thank you!!!

Edit: if I deleted the discovery topic, it returned to “sonoff”. Had to set it to “homeassistant”, which immediately showed all devices available :+1: