No entities displaying for ESPHome devices/integrations

I’ve been doing some long overdue housekeeping on my HA install. I’ve upgraded ESPHome to 1.14.2 (through and am having issues getting my entities to appear in HA. I’ve even gotten to the point of removing all devices (including removing the home-assistant_v2.db to create a new one), uninstalling ESPHome and starting basically from scratch.

In ESPHome I’ve successfully added my light, i can see it’s online here.

Going to Configuration > Integrations > ESPHome I added my light ‘successfully’… however when i click into it I see the Device info screen with the following info:

by espressif
In Cinema
Firmware: 1.14.2 (Nov 7 2019, 13:54:52)

BUT that’s it, no entity info/options are below that and if I go to Developer Tools > States and filter the current entities on “light.” I don’t see it.

I’ve also confirmed it’s not in “Unused entities” and no related errors in the HA Logs under Dev Tools.

Am I missing anything obvious, can anyone help?

What does the esphome logging say?

This is what i have in the ESP Home log, nothing unusual to my eyes:

INFO Reading configuration /config/esphome/cinema_light.yaml...
INFO Starting log output from cinema_light.local using esphome API
INFO Connecting to cinema_light.local:6053 (
INFO Successfully connected to cinema_light.local
[20:04:11][I][app:100]: ESPHome version 1.14.2 compiled on Nov  7 2019, 13:54:52
[20:04:11][C][wifi:409]: WiFi:
[20:04:11][C][wifi:277]:   SSID: [redacted]
[20:04:11][C][wifi:278]:   IP Address:
[20:04:11][C][wifi:280]:   BSSID: [redacted]
[20:04:11][C][wifi:281]:   Hostname: 'cinema_light'
[20:04:11][C][wifi:285]:   Signal strength: -44 dB ▂▄▆█
[20:04:11][C][wifi:289]:   Channel: 11
[20:04:11][C][wifi:290]:   Subnet:
[20:04:11][C][wifi:291]:   Gateway:
[20:04:11][C][wifi:292]:   DNS1:
[20:04:11][C][wifi:293]:   DNS2: (IP unset)
[20:04:11][C][logger:175]: Logger:
[20:04:11][C][logger:176]:   Level: DEBUG
[20:04:11][C][logger:177]:   Log Baud Rate: 115200
[20:04:11][C][logger:178]:   Hardware UART: UART0
[20:04:11][C][captive_portal:169]: Captive Portal:
[20:04:11][C][ota:029]: Over-The-Air Updates:
[20:04:11][C][ota:030]:   Address: cinema_light.local:8266
[20:04:11][C][api:095]: API Server:
[20:04:11][C][api:096]:   Address: cinema_light.local:6053

I edited the IP addresses btw

It tells us nothing, it will go on longer than that.

By the way no-one cares, or can do anything with, your internal IP addresses.

Ah yes, good tip.

That’s literally the full log unfortunately, just tried it again and stops in the same place…

What is in your YAML for the device?
Are there any sensors/switches/lights, etc.

Or just the wifi, api, and ota?
If you don’t have any components, then there is nothing to display in HA.
Assuming you do have components, share your YAML so we can see if there are any problems.


So I wound up updating a name in ESP Home for the light bulb just through being OCD, flashed it and to my suprise it all worked. I assume that maybe it didnt fully complete the flash previously.

Today I had a similar issue. Lights and buttons are visible in Developer Tools/States,
the Sonoff (4ch) itself is shown in Configuration/Integrations, but with an empty entity list.

Removed it’s whole folder in /etc/esphome/{devicename}, except the yaml and compiled it once more. Now all entities show up as usual.