No events from netatmo camera


I’m using the netatmo integration with yaml configuration inlcuding proper id and secret as per netatmo app.

On the netatmo app I had occasional ban during my tries, now status is unbanned. Also there, redirect URl is like ` and webhook URI is empty

External URL in HA is set as `

I can see the cameras live flow.

I have no errors on the HA log but in the system log (CORE) I cannot see the message " INFO (MainThread) [homeassistant.components.netatmo.data_handler] Netatmo webhook successfully registered" but only “INFO (MainThread) [homeassistant.components.netatmo] Register Netatmo webhook: `”

I believe I have a problem in the webhook registration therefore… any suggestion on how to proceed? I have tried more or less all what as been proposed in similar threads

Right now, Netatmo service is at least for me down.

  • no streaming
  • no lights (web hook)

looks like a different problem, in my case I have a perfectly working stream and the service is reported as green by netatmo

Issue solved but I have to say that the documentation is very poor about…look like home assistant is listening only on 8123
I had to forward all three external ports 8123, 443 and 80 to 8123 internal port, then it worked. I hope this will help someone

The documentation says explicitly that in order to receive events from Netatmo, your Home Assistant instance needs to be accessible from the web over port 80 or 443.

What is poor about that?

It does not mention that it is not sufficient to open one of the two ports but also that the port has to be forwarded internally to the local port 8123. Looks like HA is listening only on that port.

To be honest, you seem to be lacking sufficient networking knowledge to be opening ports to the WAN safely. Otherwise it would be self explanatory.

To be honest the documentation is not self explanatory, if not this forum would not be full of people asking help configuring this specific integration

To be honest you are rude

Have a nice day

I am sorry if this came out rude to you. This was not my intention.

There is actually more to it than just opening ports on your router and forwarding them to your HA instance on port 8123. By opening up those ports you are exposing your instance to the web, so it is really a strong recommendation to secure the communication (SSL) and your account along with your whole installation.

So I was rather expressing my concerns than trying to insult you.

1 Like

how to handle that if you’ve a traefik proxy in front of HA ? I can’t redirect directly 443 and 80 to HA virtual machine. And I don’t want to expose it directly to internet also.

I don’t think it matters which proxy you use. You have to expose your instance regardless. Allowed ports for webhooks are 80, 88, 443 and 9443.