No external internet access

For no clear reason my HA instance can not longer access the external internet.

My Nabu Casa sign in won’t work on the Pi (online login fine), together with many integrations that depend on the cloud. Anything LAN related is fine. Its as if external access has been switched off.

I think it might be a DNS issue but i haven’t changed anything so no idea.

I’ve rebooted a dozen times and it makes no difference.

Any ideas?

Home Assistant 2023.7.0b0
Supervisor 2023.06.4
Operating System 10.3
Frontend 20230628.0 - latest

Try pinging
Then try pinging

If the IP works but the hostname doesn’t, then it confirms a DNS problem. If neither work then you’ll want to look at general internet connectivity for HA.

Thanks for the reply.
yep i ran the ping command from the HA terminal and it worked fine.

I’m now attempting to roll back the core to the stable version rather than beta to see if that works.

So far it seems to have downloaded it and is rebooting by itself.

Supervisor 2023/06/4 is problematic. Broke my mqtt bridge entities, broke lots of things for others. Restart(s) required after update to latest 2023.06.4 (restarted 3 times) · Issue #4414 · home-assistant/supervisor · GitHub

Having same issue here, just spent an age upgrading UDM pro and restarting / looking for network issues.
I had issue with Studio Code Server addon yesterday and today all my cloud integrations will not connect, ping and works fine but does not
Appdaemon will not start and config check will not work unless I comment out REST !

yep same problem for me. Ping to ip is fine but not to dns. Rolling back the core made no difference. I understand rolling back the supervisor is possible but it will auto update? Problem now is will I ever get a fix from HA if I can’t access the web.

The fix :

ha supervisor reload
ha multicast update --version 2022.02.0
ha dns update
ha dns update --version 2022.04.1
1 Like