No haos after new installation only debian(solved)

So i finally decided to replace my extensive Fibaro installation with HomeAssistant.
Bought new raspberry pi 4gb, sandisk extreme 32 gb, good 20w power and micro hdmi cable.
Followed installation manual using both etcher and imager.
Tried 2024-03-15-raspios-bookworm-arm64-full.img and also the lite version.
Booting the RPI4 and i see all no errors. Wifi connects, SSH on port 22 working but nothing on 8123. Monitor shows login prompt NOT the HomeAssistant logo.
I can login with my username from the installation. I see only regular debian stuff, nothing on hasos but i cannot su because root password not known.
Look like i am missing a final step?

I believe you are on the raspberry pi os image. For HASS OS, i’d recommend you use Raspbberry Pi Imager, and select Home Assistant OS in there

Which Installation Manual ? Which User-Name/Login-Prompt ? ( Some Name you wrote during installation of Raspberry PI OS ?, Or did You ever reach the “HA Onboarding Screen” ?

And btw Do People really buy 32GB SD Cards, now a days ? , for Devices other than those which only supports up-to 32GB (old timers).
When an Installation Instruction says 32GB OR More, It kind of tell People, You can “prepare” for the future, if you intend to have a “Larger” Install, than Average-Default etc, it doesn’t mean You Have To go out and Buy a 32GB sd-card

Welcome to the community! :slight_smile:
It looks to me, as if you hadn’t installed Home Assistant, but a plain RaspberryPi-OS?! :slight_smile: Sorry to say, your post seems a little confused. :slight_smile:

So let’s take a step back and start anew. Download or open the newest version of RaspberryPi-Imager. Now, choose the OS to flash by
OS > Other specific-purpose OS > Home assistants and home automation > Home Assistant > choose the version for your Pi (RPi 4/400)

Let the Imager do its work, and than install this version onto the Pi4. This will install Home Assistant-OS (HA-OS) on your Pi. This is the easiest way to get to a working HA installation.

Just to note, there are other installation methods available, if you want to choose one of them, like supervised (not recommended) or container, let us know, what you want to achieve and we can help you with these ways as well.

Thanks @vmod, @boheme61 & @paddy0174, you where so right.
As an it engineer i am not really used to reading manuals :wink:
I missed “Select Other specific-purpose OS > Home assistants and home automation > Home Assistant.” from the installation guide and went straight for the 64bit rasberry pi os TWICE.
Web interface on 8123 is now working and am setting up my Z-stick and z-wave devices.
Good to learn that the HA communinity is so active as to have the right answer in minutes as opposed to Fibaro which is kind of dead.
Looking forward to many hours of tinkering with this stuff.


Good you got it working! :+1: Have fun with your new installation, there is SO much to explore!