No IP address after a reboot

Good morning all,

Yesterday midnight my area had electricity issue and when the issue was fixed I noticed that HA was dead.

I restart my Proxmox server using the console and i noticed that there is no IP address:

My ProxMox settings:

I restart my router several times, with different settings and i even reset it to factory defaults but still no luck. Note that after the electricity issue fixed in the area all network and wifi devices are connected successufully. The only issue i am facing is with my HA server.

I am hoping that someone out there has a fix for me.

Thanks in advance

It could be so many things…

Did it have a static IP before (not a DHCP reservation)? Is the storage corrupted and hence some configs (including network config)?

Is it connected via WiFi? If not, did you test or swap the ethernet cable?

Any logs that show its even attempting to connect to the network? Any logs on the router?

It has a static IP in the router using the virtual MAC address.

Storage looks to be ok. But how can i check and where can i find the log? I am not familiar with hasoss

I had the exact same issue. I woke up this morning and couldn’t connect to the dashboard,
I thought it was due to upgrading to 2022.4.4 but you’re still on 2022.4.2.

My Proxmox config is identical to yours (save for a different IP scheme), have you updated Proxmox recently? I’m on 6.4-14 with all updates installed…

Something was messed up with DHCP, I set it manually on the HA console with the below command and that restored access:

network update enp0s18 --ipv4-method static --ipv4-address --ipv4-gateway --ipv4-nameserver --ipv6-method disabled

Obviously you’ll need to adjust the above to match your network settings.

Good luck!


Wow, I thought I was the only one! The EXACT same thing happened and I thought my N2+ was fried.

What I did was connect a monitor up to the device and a keyboard. Then in the HA boot up prompts, I stumbled my way into turning off IPV6 and using IPV4 in the network settings…for some reason above my skill level, this worked.

Also note, I had a static ip as well, and had to delete it and Let it connect to the internet with a new ip address.

One note - after connecting, I changed the static ip address in HA back to the old IP address and everything works back to normal.

The odd thing is, when I changed the assigned static IP in the ROUTER settings back to the old ip like I did in HA and everything quit working again. I reverted back to the new ip in the ROUTER and fixed it. My troubleshooting made me believe some setting got changed and caused the assigned static ip in HA and my router to conflict. That’s my best guess…but everything is back to normal now.

Finally i found the issue. I delete the network device in Proxmox and create a new one

Thank you for the troubleshooting help, every other thread I found just suggests to reinstall Home Assistant completely.

I did however have one stupid question: How do I determine what IP my nameserver should be?

I’ve tried both my router address and pi-hole address. Neither have worked, and when I check “network info” under ipv4 it just shows “nameservers: [ ]”. I do see an IP address for my HA VM “enp0s3” on boot now and see the VM in my routers device list, but still can’t access HA using the local ip:8123 or homeassitant.local:8123.

I’m happy to do a fresh install, but was hoping to figure this out in case I run into the issue again.


That sounds like a work-around. Not a solution.

On mine, the /etc/network/interfaces file was renamed to interfaces.real and a vanilla interfaces file was installed. Some hassio/supervisor update must have done it.

network update enp0s18 --ipv4-method static --ipv4-address --ipv4-gateway --ipv4-nameserver --ipv6-method disabled

this method work thanks

for me I installed the 32 bit version and then run what bill suggested:

network update enp0s18 --ipv4-method static --ipv4-address --ipv4-gateway --ipv4-nameserver --ipv6-method disabled

and then it worked