No more notification when not connected on home network

Hi there,

Since two weeks, I don’t receive the notification sent to my iOS device when I’m not connected to my home WiFi network. In short, only local push seems to work.

What may have triggered this issue
Two weeks ago, the location of my phone was not updating anymore. So I deleted the device on HA and the server on the companion App, then added it back. Since then location works, but not the notification when abroad.

Steps taken so far to try to fix this issue

  • Tried, to delete the device on HA, remove server on iOS, add it back. No change
  • Checked on my phone that all notifications are allowed. Everyting is ok, and anyway, notifications works when connected on home network
  • Reset the Push ID, force quit the app then re-launch
  • Send a simple notification from the developpers tool (Works when connected to my home WiFi, doesn’t if I switch to 4G network for example)
  • Tried to rename my device in order to either update it’s entity name on HA or create a new one, but that didn’t work either.

So yeah I’m a bit running out of ideas on how to fix this issue :confused:

So if you encountered this issue or have other things I should try, I’d be more that happy to try.

Olivier B.

So I finally got it working. I did the following :

  • On the App, Settings → Companion App → Debugging → Reset
  • On HA, remove the device in the Mobile App Integration
  • Delete the App from the phone
  • Re-install the App
  • Accept all access request to notification/location/focus etc.

The settings were kept so it directly reconnected ton my HA and tadam notification while connected to the LTE network worked \o/