No Notification Target with Mobile App Integration / Android Companion App

Dear community,

I recently started my HA journey and I am currently performing the setup for all my endpoints. Unfortunately I am really struggling with the Mobile App Integration, specifically the Notification Service.


  • Other sensors are showing up fine
  • Notification service is not available (e.g. not showing up for Automations)

Resolution approaches already taken:

  • I followed the guide for the companion app to setup the app (including the permission for notifications)
  • I tried the troubleshooting steps to restart fresh
  • I disabled all my VLAN ACLs to be sure that there is no port, mDNS or similar networking issues
  • Various addings and removals of the integration and app, with all kinds of restarts in-between

Did I miss some kind of setting or do you probably have any further ideas on how to get this working? It’s driving me crazy.

Thank you already for your support!

If you look at Developer States > Services, what notify services do you see?

1 Like

Oh man, I feel so stupid now. It is indeed listed there. I misunderstood the user interface and thought I had to select the “Send Notification” Action and a device afterwards, where I expected then my phone to appear:

Whereas the documentation clearly states you should use


This was somehow counter-intuitive for me.
It works now - thank you for this impulse in the right direction!

1 Like