No raw configuration editor

Very new to home assistant. I am trying to make a lovelace dashboard to control my tasmota pool control and some zwave devices in my home.
At this point I am so upside down with this thing and it makes no sense to me.
I understand that when you create a dashboard in lovelace it is ui controlled. When i try to edit the dash it asks me if i want to take control. I do so and it does not give me a raw configuration editor. I need to get to that to install keymaster. I have tried changing my lovelace entry in the configuration.yaml from storage to yaml mode and back and it doesnt work. If i change to yaml mode, 4 addons in HACS wont load properly. If i want them to load properly, I have to switch back to storage mode.
Additionally i have nothing in my ui.lovelace folder.
No clue where to go from here.

After entering UI edit mode, click the three dots icon again, Raw configuration editor should be one of the options.

When i do that i still have no option for the raw editor. In fact i found the problem was that i have an add on called custom header which was causing the issue. Once i removed that, everything worked fine.