No side menu items appear when accessing HA from remote browser

Good day to all

Please excuse the wrong names by which i refer to the menus. Couldn’t find the proper reference to the menu’s in the documentation.

Am puzzled why in spite of what seems to be a straightforward, text book install on an RPI of, what happened in reality did not follow the videos.

I downloaded Home Assistant for RPI3 model B ( hassos_rpi3-64-2.12.img ) which is version 0.95.4

Did a fresh install of following juan m tech’s video and written guide. the RPI was ethernet linked and so didn’t have to prepare the usb drive to configure wifi access. i attached a monitor / keyboard / mouse to the RPI to monitor the installation.

After giving the setup enough time to download HA, I accessed the RPI from a laptop via http://hassio.local:8123. i configured the name / username / password then entered HA. Clicked on the 3 lines on the upper left hand to bring out the side menu

When i clicked on Hass.IO to bring out the Add-On Store, the webpage hung for a while until an error message of

“Page Unresponsive
You can wait for it to become responsive or exit the page”

appeared. Selecting “Exit Webpage” closed the screen and brought me back to the “Logging in to Home Assistant Local” page

Entering username / password brought me back to the HA page. Clicking on the 3 lines on the upper left hand brought out the same unresponsive side menu. And the repeat of the error and time out of Home Assistant

To isolate the error, I did a fresh install of Ubuntu 18.04 desktop on a PC and followed the instructions to install Hass.IO on Ubuntu by Frenck. The HA version is also 0.95.4

After Home Assistant was installed, I then accessed its webpage from a Firefox browser on the Ubuntu PC and a laptop on the same switch as the PC

The laptop showed the same error as when it remotely accessed HA on the RPI. The Firefox browser on the Ubuntu PC ran correctly, being able to access all the side menu items ( Overview, Map, Logbook, Hass.IO, Configuration ) and display their sub options. I was able to display the Add-On Store of Hass.IO and select Configurator

Has anyone come across this behavior? Would anyone know why I’m not able to display / access the options of the side menu of Home Assistant?

Thank you

Are you using some kind of JavaScript blocker extension?

hello #flamingm0e. nope no blockers no extras. just did what Mr’s Juan M Tech and Frenck presented in their respective video instructions and written guides. Even assumed the possibility my sd card was corrupted and so formatted 2 of them and repeated the twice only to experience the same error