No space :(

Running hassio, but it’s telling me I have no space left. I’ve deleted snapshots etc…

How do I make the virtual partition (or whatever) bigger? The SD card is plenty big enough so I’m guessing it’s the containerised part of it.

It may be that this is erm, outside my area of expertise, but I seem to be locked into the container, and I can’t even use apt to install. I would use a custom raspbian build, but I tried that and it doesn’t have the right versions of Python etc (went down a bit of a rabbit hole trying to compile it, and missing dependencies!). I just keep hitting brick walls no matter what I do :frowning:

You should update to Home Assistant OS. Hassio hasn’t been a thing since January 2020.

Seriously, please stop using this term as it only confuses new users.

1 Like

Well I guess I’m one of those that it’s confusing to. I’m running what I recently downloaded,and I didn’t get the memo about what not to call it.

You did get the memo of what it is called though:

1 Like

I’ve seen Hassio mentioned in many places, and thought that was an abbreviation. Sorry, but I had no way of knowing that I was committing a mortal sin, I didn’t mean to offend anyone :wink:

2 Likes

So, any chance of a steer as to how I can increase the space of the Home Assistant OS partition? Containers really aren’t my thing. :frowning:

Ah, I can see where I’m getting hassio from - my snapshots (that I can no longer create due to the space issue) are clearly being automatically labeled “hass_io…”?Screenshot 2021-04-23 at 12.21.19

I am running the latest version as well!

Whatever is creating those snapshots needs updating. There are actually a number of places yet to expunge it from.

So I’ve installed HA core on Debian to get round the lack of space issue. But there’s no supervisor menu, so I can’t find out where to restore my snapshot??! Arrrgh! What gives?

So it’s not ‘supervised’ it seems, so I can’t restore a snapshot? I’m going round in circles again. I even installed it on a PC so I could install Bullseye as the latest Raspbian doesn’t have >=Python3.8

Can’t find install instructions for Deb11 / non-rpi. Where do I go from here?

@tom_l calm down

1 Like

I’m calm as a Hindu cow.

2 Likes

I can see your going round the bend here!!

Im installed on Debian 10 and have the “Supervised” menu as I am running “Home Assistant Supervised”

Try and follow the instructions at Installing Home Assistant Supervised on Debian 10 and you will get a Supervised install and then the ability to restore from snapshots etc. Id recommend the Google Drive snapshot addon too Add-on: Home Assistant Google Drive Backup

I agree that the naming conventions of Hassio, Home Assistant OS, Supervised, etc are all very confusing and I had to search just when posting this to let you know I was running what is called a “Home Assistant Supervised” system. The dev team have tried their best to make things straight forward but it is difficult when reading old posts to know whats what.

The analytics released recently has surprised me that I am only in around 13% of people that run Supervised. I guess when you run a system day in day out you just assume people do the same. https://analytics.home-assistant.io/

1 Like

Thanks Craig, that’s really helpful.

The only issue with building on Debian 10 is that it complains that Python3.7 (which ships with Deb10) is too old. So it’s then necessary to compile a later version of Python, which when I tried (a couple of times), it was still failing for dependencies etc.

I’m not sure how much this matters - for example will HA be ok with Python3.7 for as long as it takes for the instructions to support Debian 11, or do the current instructions for Deb10 apply to Deb11 also etc etc?!

I can’t help on that point sorry.
I’ve just checked and im running python 3.7.3. I set up Debian (moved from an Ubuntu setup) about 6 months ago and can’t remember any issue about python versions.

I had a message during installation that Home Assistant will not support Python <3.8 very soon, hence my concern. Hopefully that’s not something that’s going to surprise everyone!

Same - I found 126 unused images lying around in my Home Assistant system.
Using Terminal addon running in priviledged mode, I executed “docker image prune -a -f” and reclaimed 30Go of space :wink:

Now, I’ve created a shell script to execute this command each night to eliminate unused images.
This is my configuration.yaml config to allow the automation to access the command :

shell_command:
  image_clean: docker image prune -a -f
1 Like

On a related note - can anyone tell me how to cli into the node red partition so I can see the files there? I’ve tried docker attach <noderedpartition> but it’s not doing a lot!?