No state available for media_player


I have upgraded my Hassbian (HA 0.85.1). Since the upgrade I have this red box with an error (no state available for media_player.denon_avrx3500h


Now my automation rules don’t work anymore (like if my chromecast starts playing --> turn on AVR and select source chromecast).

The weird part (for me) is that my AVR is still listed on the home page and I can control the AVR manually (turn it on/off, select source, etc.).



Does anyone have seen this error before and knows how to fix it?

In the meantime I’ve successfully performed a rollback to 0.84.6. The error is now gone and the automation is working again, but I can’t stay forever on this version.

Does anyone have an idea?

I did a clean install into a new VM. Clean config of everything except the onkyo media_player component. Worked just fine in every version > 0.84.6 I tried. Must be something with our configurations.

I still haven’t nailed down the issue in my live setup.

Seems like your entity_ID is wrong. Check if the name still matches. (there was a change in how entity id’s handle stuff like ’ - % @ etc.

I ended up resolving my issue. Seems it was a configuration problem. I had “sources:” without any values.