No update shown since 2022.4.0

Hi guys,

for a couple of weeks now, I have to manually update HAcore in the terminal. I am not able to see any core or OS updates in the new update section of the settings. Is there any way that I can get that back?


What type of install do you have?

Is it healthy? (Settings > System Health)

it’s Home Assistant OS and everything is OK, no error messages.

I had a period of time where this happened to me. It turned out to be my router (pfsense) running unbound. The unbound DNS resolver has a known issue resolving github links. For awhile I had to restart unbound, then restart supervisor, for HA to see the updates. I am running HA ON on the Blue. Not sure if this helps you…

Interesting. I just installed unbound, yesterday. So it can’t be that, since the problem is going since before. But thanks for the input!

I have the same problem, but from 2022.4.7. I dug a little bit on the command line and there seem to be two issues for me. When I enter ha supervisor available_updates I am told that 2022.6.2 is available, however when I then enter ha supervisor update I receive the message

Error: No supervisor update available - 2022.05.3

When I do ha available-updates I get

ERRO[0000] Unexpected server response. Status code: 403

@dinyar Are you able to open a browser, and navigate to the following: Releases · home-assistant/core · GitHub

If so, that rules out DNS issues for you.

Ah yes, I can reach it. I now read the original message in more detail and it looks like this is a different problem given that I cannot update via the command line either.

I had the same problem and found a link to a related GitHub issue. I didn’t save the link, but the cause of the problem was a misbehaving addon.

I removed any unnecessary addon and after that the update showed up.

Let me know if you need the link and I’ll look it up again.

I am having same issue as dinyar, it is not DNS as can open the github page via a browser, so any more information @oskarsyren would be helpful. I can update manually as have done the last few times, but nicer to do it via the GUI

Here is a link to the commit that I think solved my issue but I don’t know since I’ve already uninstalled the problematic add on.

Before removing the problematic add on I noticed that the update entities were listed as “unavailable”.
You can see issues from more users with the same problem in the links found in the pull request.

Well, I deleted some unused add-ons and updated to homeassistant OS 8.1. Let’s see what happens. I don’t seem to have a DNS problem. I can reach github pages just fine. I had this issue once before and reformatted the hard drive and reinstalled homeassistant with my backup. That worked. But I am kind of not in the mood to do this again. :laughing:

I’m having a similar issue, and all my update entities are normal and showing update available (where applicable). Also validated DNS.

ha supervisor update tries to update supervisor. That is correctly returning an error because you’re on 2022.05.3 of supervisor already (the latest available version at this time).

Sounds like you want to update core. To do that enter ha core update.

1 Like

This worked for me!

What worked for you? My problem still isn’t solved.

The comment above by CentralCommand

Sounds like you want to update core. To do that enter ha core update.

Yeah, I know. I can only update HA core with this command in the command line, but the update will not show up in the GUI.

Finally got round to looking at these links and it was becuase I had disabled entities for the home assistant integration. I enabled anything with ‘update’ in the name and now I get the Update Available prompts in the Settings page. So all good once again

1 Like