No updates available / found

I’m on 2022.6.6 and on the update page I get no updates available. Even after pressing the refresh button. I have this problem since the introduction of the update page. Last update I ran I did through the CLI. How is this possible? My internet is not blocking anything, as far as I know.

You migth want to try to clear your webbrowser cache or try a different one (Edge is waiting for you :stuck_out_tongue: )
Any messages in the full log?

Just tried Edge, but no updates either. No log items related to this issue as far as I ca tell.

Change your dns server in Settings > System > Network to, or

Rebooted host to be sure after change. Still not working.

Do I guess right as in I’m the only one having this problem (or nobody else tries to upgrade their system)?

And their is no clear reason or error for this problem?

Only errors I can’t figure out what they mean are:

Logger: aioshelly.block_device
Source: /usr/local/lib/python3.9/site-packages/aioshelly/
First occurred: July 14, 2022 at 1:12:47 PM (1 occurrences)
Last logged: July 14, 2022 at 1:12:47 PM

device initialize error - TimeoutError()


Logger: aiohttp.server
Source: /usr/local/lib/python3.9/site-packages/aiohttp/
First occurred: July 14, 2022 at 5:59:58 PM (4 occurrences)
Last logged: 11:05:21 AM

Unhandled exception
Traceback (most recent call last):
  File "/usr/local/lib/python3.9/asyncio/", line 1192, in _sendfile_fallback
    read = await self.run_in_executor(None, file.readinto, view)

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/local/lib/python3.9/site-packages/aiohttp/", line 514, in start
    resp, reset = await task
  File "/usr/local/lib/python3.9/site-packages/aiohttp/", line 460, in _handle_request
    reset = await self.finish_response(request, resp, start_time)
  File "/usr/local/lib/python3.9/site-packages/aiohttp/", line 613, in finish_response
    await prepare_meth(request)
  File "/usr/local/lib/python3.9/site-packages/aiohttp/", line 286, in prepare
    return await self._sendfile(request, fobj, offset, count)
  File "/usr/local/lib/python3.9/site-packages/aiohttp/", line 99, in _sendfile
    await loop.sendfile(transport, fobj, offset, count)
  File "/usr/local/lib/python3.9/asyncio/", line 1171, in sendfile
    return await self._sendfile_fallback(transport, file,
  File "/usr/local/lib/python3.9/asyncio/", line 1201, in _sendfile_fallback
    await proto.restore()
  File "/usr/local/lib/python3.9/asyncio/", line 268, in restore
  File "/usr/local/lib/python3.9/asyncio/", line 343, in resume_reading
AttributeError: 'NoneType' object has no attribute 'resume_reading'

In the CLI i get this when I run ha available-updates:

ERRO[0000] Unexpected server response. Status code: 403

403: the server understood the request but refuses to authorize it.

Odd… So I’m reaching the update server, but for some reason my connection is denied at the end?

I still don’t understand this. The availability check does not work and gets an 403. Though when I execute ha core update or ha os update it updates just fine. What is so different about these two requests?

And again this month no update available, but via cli I can update. How can I solve this core issue without errors?

Ok, this is still a major issue for me, Exchanged my router for this. No help. Put in custom dns addresses via CLI. Still no solution. Reinstalled HA from scratch and put back a backup. Still no updates available. If I check for updates through the CLI it says 403.
But if I do ha update it does update to the latest version. Beats me…

Please advice, should I create a Github issue? Or does someone have another answer?

I was having the same issue just a week ago. It looked like described above

  • ha available-updates was returning the results just fine
  • the add-ons page was highlighting the add-ons with updates
  • but the updates weren’t showing up on the settings screen and no notification was displayed.

It was resolved when I did an update of core from CLI. Not sure what was the root cause…