No vibration when sending notifications to my Sony Xperia XZ2?

I’m trying to set up vibrationPattern in a channel, but it doesn’t do that.
Looking in settings under the apps notifications I don’t see my channel either.
I see two channels Default Channel and General. Notifications seems to flow to General.
I’ve built this payload in node-red:

   "data": {
     "message": "Alarmen for Bøgehegnet 10 er {{ payload }}",
     "title": "Alarm er {{ payload }}",
     "data": {
        "tag": "alarm",
        "color": "{{ color }}",
        "data": {
          "channel": "alarm",
          "importance": "high",
          "vibrationPattern": "100, 100, 100, 100, 1000, 100, 100, 100, 100, 100, 1000, 100, 100, 100, 100, 100, 1000, 100"

No need for the last data entry. Move those 3 settings to the same data as tag and color.

1 Like

BINGO :slight_smile:
Still won’t send notification if the phone is in standby :frowning:
The App is excempted from battery savings.

You need to set ttl and priority.

See the Android example at the bottom

I see, ok, so the docs say to use channel’s, and then ON TOP of that use this? Or am I (probably am) misreading the docs?

Look at the provided examples and the parent > child relationship with how they nest under data there is only one data element after the message and topic which is where all the rest of the notification options go.

It’s not the structure I ask about, but the text says:

For Android these notifications are designed to show up on the phone immediately. By default they do not override Do Not Disturb settings, if you would like to override this you will need to use notification channels. They also do not make the notification sound when the phone is muted.

But the example below it then shows

  - alias: 'Fire Detected'
    - platform: state
      entity_id: sensor.smoke_alarm
      to: 'smoke'
    - service: notify.mobile_app_<your_device_id_here>
        title: "Wake up!"
        message: "The house is on fire and the cat's stuck in the dryer!"
          ttl: 0
          priority: high

I think you misunderstood that part. Waking up the phone is completely different than overriding the Do Not Disturb setting on your phone. What we mean here is that if your device is in DND mode and you are not using a channel that was set up to override it then it won’t be delivered timely. These are 2 separate features that could work together if you need them to. You probably want to test the combination to see what works for you :slight_smile:

1 Like

Ahh, I see, ok, that makes perfect sense :smiley: Thankyou for explaining it to me!

1 Like