No Web Interface after update, but shows network is connected

Decided to update today and what a disaster. Was in Home Assistant in the browser as usual. Updated the OS: 6.0 and Core: 2021.6.5
Now can’t get into it with the browser. Can get into it by attaching a monitor and keyboard.
Some of the things have tried.

  1. while rebooting looks fine, get all green OK’s.

  2. core check, core rebuild, even tried downgrading the core and it does it so fast know it didn’t do it. Says it did, but still says same core, even after restarting.

  3. supervisor update, same as core issue.

  4. restore from backup. If that saves the previous core,… than that didn’t work either.

  5. after booting up it shows the correct ip address for wan and lan and the ports (currently connected lan). So the network is working can even see Rx/Tx packets building in router. Can ping it also.

  6. This last thing going to mention not sure if was there earlier or not. Maybe I caused it messing around???
    core logs now show:[homeassistant.util.json] could not parse JSON content: /config/.storage/core.area_registry

    If search for it it is in /mnt/data/supervisor/homeassistant/.storage/core.area_registry but think it isn’t creating the config directory to mount it there?!

  7. Also just noticed in supervisor logs: SnapshotManager.do_restore_full blocked from execution, system is not running - CoreState.STARTUP. So that is bad.

Not sure where to go from here except copy configs,… from SD card and reimage.

Any ideas?

Do you have a snapshot from before you were…


Yes. Multiple ones, back since Jan and backed up before updated today. But looks like #7 they aren’t working cause says system not running.

Yeah, you might have to copy off the snapshots and re-image home assistant. The restore a snapshot during the 1st onboarding screen.

So did just that. Copied the latest backup over to the SD. After onboarding selected the backup and checkmarked all but the Core since had the latest core on it now. Still got that

So doing it again, but not going to select any of the addons, just my config files. Might select the Zwave cause that is all I have.

**Later: Finally back up partially. The phone app isn’t connecting yet. Do have the wifi working again. My original core.device_registry and core.area_registery keep giving the core log error about parsing.

This time after onboarding made a dd image. Had to use it. Have the latest image, but looks like a long road to get back. My backups won’t work it seems. I did copy over my network wifi setting and zwave configs except for stuff in .storage (waiting on that).

Still only partially back. Couldn’t do a restore in WebUI cause it kept saying the system was still in startup and wouldn’t quit. Was able to do a full restore from cli only. It wouldn’t let me do partial in cli. Some of my devices are working and have network up.

Looks like Z-Wave is only partially operational. I originally had the one called Z-Wave (not the OpenZwave). Now only see OpenZwave and Z-Wave JS. Seems like Z-Wave wasn’t saved in the snapshot (found out was wrong on this later). So when go to integration it is missing part of it. I see here: core/homeassistant/components/zwave at dev · home-assistant/core · GitHub can get it, but not sure how to install it. If someone knows a guide of where the files go please inform. Just want to get the system back up to functional like it was before started this messy upgrade that failed. Then can do a dd image and then work on Z-Wave JS or something.

  1. Z-Wave JS is still in beta right!?

After a hard reboot it appears to be working again!!! YAAA. Definitely doing a dd image of the SD card before anymore upgrades,… migration to Z-Wave JS,…

*Lessons learned:

  1. use dd to make a block level copy of the SD card. Save as backup incase things go bad. Take about 90min to put it back on a 64GB card, but worth it.
  2. Maybe make a 2nd SD card ready to go incase busy and don’t have time to recover from problem or if orig SD goes bad.
  3. Found can’t restore partial snapshot from CLI. Seems would only let me restore full snapshot.