No zwave usb with new hassio image install


I previously has a working zwave usb with version 0.48. I decided to wipe that and install the hassio image and now I don’t see the usb device. It is a Z-Wave.Me “uzb” and used to show up as something like /dev/ttyACM0.

I tried unplugging/plugging in but no luck. I honestly don’t recall if I had to install anything before, I think it just showed up automatically.

Any ideas?

Did you read this page?

Yes. Like I said, the device doesn’t show up under /dev

you said it doesn’t show up under /dev/ttyACM0, have you tried /dev/ttyUSB0? or /dev/ttyACM1?

Ok, sorry, if I ls /dev it isn’t there. Maybe I’m having a brain fart and this isn’t how you check?

core-ssh:~# ls /dev
char init null random stdin urandom
fd kmsg ptmx shm stdout zero
full mqueue pts stderr tty

well, I don’t know if the SSH add-on sees the devices. the SSH add-on is running in it’s own container.

Dang I was wondering that. Silly me I haven’t even tried to just add the zwave config. I wanted to just verify which device it was.

When I get home from work I’ll just try ttyacm0.

I guess there’s no way with the hassio image to view device names?

SSH to the SSH addon on your hassio box and run hassio host hardware. It will list the serial devices visible by resinos.


Great! Thanks. I’ll check when I get home.

OK, it was there. Thanks for all the info!