Home Assistant Community

Noaa_tides

#1

Hi All… fairly basic problem. I’ve been running Hass.io for about a month now and have been slowly bringing everything in my house that is able to be controlled by home assistant under one roof.

As I’ve gotten core items setup I am starting to branch out into the nice extras … the first being noaa_tides as I live out by the beach.

I believe my fundamental problem is how am I supposed to install any of these python scripts? Where do the scripts go? How are they executed? Link link to project below for what ever that is worth…

I’ve done a lot of reading regarding how to configure various things and get them running, but I’ve got to me missing something fairly basic on this one… Any help would be appreciated.

0 Likes

#2

I believe you just set it up in your configuration.yaml since it is a component of Home Assistant and, by extension, Hassio.

0 Likes

#3

what python scripts are you referring to?

the link you posted doesn’t mention any scripts that i saw.

0 Likes

#4

Maybe not tour scripts per se, but the sensor.py and init.py files.

When I add the sensor to the configuration.yaml file it will either generate errors or simply doesn’t become an available sensor … hence me conceding that I need to somehow do something with the .py files.

0 Likes

#5

Sensor.py and init.py files from where?
I do not think this sensor requires any files other than Home Assistant.

0 Likes

#6

what errors are you getting?

I just copied the config from the link you provided and placed it into my sensor: section in HA and it worked exactly like it should.

sensor:
  - platform: noaa_tides
    station_id: 8721164

Where are you putting that config for the component in your HA set up?

1 Like

#7

After seeing this, I gave it a try, too. Looked up a nearby tide station ID and added the sensor exactly as above (below some other sensors I already have defined.) I did the “Check Config” and it showed valid.

HA won’t restart. No Lovelace, nothing in the home-assistant.log, just dead until I restore the old (unchanged) configuration.yaml and reboot the R Pi.

I did this a few times, in case I’d made a mistake with spacing or something. No improvement.

0 Likes

#8

I just tried on Hassio 0.91.3, latest. There appears to be a Python module missing in the Docker container. I may be able to troubleshoot more this evening when I get home.

Unable to prepare setup for platform noaa_tides.sensor: Could not install all requirements.

8:51 AM setup.py (ERROR)

Not initializing noaa_tides.sensor because could not install requirement py_noaa==0.3.0

8:51 AM requirements.py (ERROR)

Unable to install package py_noaa==0.3.0: Failed building wheel for pandas Command "/usr/local/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-4p16wnn8/pandas/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-v5g4e3mx/install-record.txt --single-version-externally-managed --prefix --compile --user --prefix=" failed with error code 1 in /tmp/pip-install-4p16wnn8/pandas/

8:51 AM util/package.py (ERROR)

Version 1.0 of py_noaa was released last December. Perhaps version 0.3 from last August is no longer available.

It appears that the noaa_tides maintainer needs to get this working with 1.0 or, if it already works, update the requirements.

0 Likes

#9

I literally just installed this component yesterday for the first time ever and it worked perfectly fine.

I’m running v91.3 in Docker on Debian OS.

I’m not sure why you would not have all of the requirements available. Unless it literally just happened that it was removed from a repo somewhere.

literally…:wink:

1 Like

#10

I wonder if the component works with 1.0 of the module.

0 Likes

#11

I have no idea. I just know it worked for me when I installed it yesterday.

0 Likes

#12

Are you running Hassio or Home Assistant?
Apparently the container homeassistant in Hassio does not have the gcc compiler needed to install dome of the module dependencies.

EDIT I see you’re running a Docker install.

Strange indeed!

0 Likes

#13

I’ve got a plain vanilla 0.91.3 installed. Hassio on a R Pi 3+ B.

Which log file is that you quoted, if I get time I can try again and see if I get the same errors.

0 Likes

#14

It was just in the Homeassistant log file.

0 Likes