Node could not removed

I have 2 nodes (and of course the driver stick) aeotec 5th gen
I have 3 switches and i have only 2 nodes, so there is a false node it has a sad picture and does not switch of course. > Everspring AN 158 unreachable and i tried to delete it but it is not deleted at all, How to delete it? (note there is no real zwave switch so i cannot press switch to reset or delete it).

does the device show as “is_failed” in the entity attributes? if so just run remove failed node command from the z wave control panel.

Nope, now it said: CacheLoad (for 15 hours!)

Also another problem is that most of the times the Homeassistant is restarted the USB port changes /dev/ttyACM0 /dev/ttyACM1. How to make it persistent to just one port?

you may just need to do a factory reset on the z stick and then re-add your other nodes. it won’t be too painful since you only have a couple of devices.

and to make the usb location persistent there are a couple of ways to do it.

the way i do it is to use a udev rule:

add the following to your 99-com.rules file (change the symlink name to whatever you want):

SUBSYSTEM==“tty”, ATTRS{idVendor}==“0658”, ATTRS{idProduct}==“0200”, SYMLINK+=“ttyUSB-ZStick-5G”

then set up your z wave on config to uise the udev name:

  usb_path: /dev/ttyUSB-ZStick-5G

another way i’ve seen seems easier but i haven’t tried it yet so…

there is no udev rule to create, just add the usb path to config:

  usb_path: /dev/serial/by-id/usb-0658_0200-if00

I don’t know what the -if00 at the end is so you may have to figure out if yours is the same or if all aeotec z sticks are the same.

with the udev rule it will work based on the settings for any aeotec z stick since those settings are universal for all of the 5th gen aeotec sticks (to my understanding at least).

Thanks! but where do i find the 99-com rules file?
I already dit a factory reset on the Z-stick. (i have 1 Aeotec stick and 2 Everspring AN158 switches but there is always a (bad) 4th node so no real node.

@Bwalberg It is far easier and safer to do an
ls /dev/serial/by-id/
and enter the resultant string as in the above example.

  usb_path: /dev/serial/by-id/usb-0658_0200-if00

Maybe i done it wrong:
~# ls /dev/serial/by-id/usb-0658_0200-if00
ls: cannot access /dev/serial/by-id/usb-0658_0200-if00: No such file or directory

ls /dev/serial/by-id/
and use what that returns.

if you decide to do the udev rule route its located at etc/udev/rules.d/

I’m not sure that the other way is easier, per se, since you literally just have to copy & paste the line i posted above to the bottom of that file. but I guess it could be “safer” in that if you somehow save your modified file wrong then it will cause problems. but again open, copy, paste, save, reboot, done.

and for completeness i just ran the ls command above and mine returned usb-0658_0200-if00 so the if00 seems to be universal to all 5th gen z sticks too.

either way should work fine.

~# ls /dev/serial/by-id/
ls: cannot access /dev/serial/by-id/: No such file or directory

So that does not work!

What hardware are you using? What OS?

Synology DS218+ with Docker DSM 6.1.5-15254 Update 1


You will need to see what else is available to you. Most NAS devices have far fewer system level tools than a full operating system.

see if you have /lib/udev/rules.d/ If so you should be able add a rule as above.

Yes i have a rules.d it is on ~lib/dev/rules.d but its not a file but a map with aboud 30 files started with 50 *50 60 @60
But which row do i edit? and what is exactly the row to insert?

look in the directory i posted above to see if you have the 99-com.rules file.