Node Red and

Has anybody come up with a way to get rid of these error messages, I get 20 of them every time i restart hassio. Looks like Node Red is trying to access some unavailable Home Assistant instance outside my network? Why?

19-10-14 14:51:05 INFO (MainThread) [hassio.api.proxy] WebSocket access from a0d7b954_appdaemon3
19-10-14 14:51:05 ERROR (MainThread) [hassio.api.proxy] Client error on WebSocket API Cannot connect to host ssl:False [Connection refused].
19-10-14 14:51:05 INFO (MainThread) [hassio.api.proxy] Home Assistant WebSocket API request initialize

It has been like this for a while. I’m on 0.100.2 on an Intel NUC/Debian stretch.

Do you have an additional server configured on that address, or with a name that resolves to that address?

Check your configuration nodes (it’s on the little down-arrow menu next to the debug icon)

No, I don’t. My network is internally and my public one is 84.x.x.x. My Node Red ‘Home Assistant’ configuration node doesn’t specify the ip address. I have checked the ‘I use’, so there no input field for ip/url. The only other one with an ip address is to my MariaDB server at 192.168.10.yy.

Have you ever imported a flow from someone else? Not sure if this is still an issue, but last time I imported a flow that includes a HA node it also imported the server config. Check your config nodes tab in NR to see if there are any other HA connections in there.

1 Like

I’ve checked. There’s only one ha connection in Node Red.

You could try to search your flows.json for the IP and see if there’s a node in there somewhere and try to remove it from there. I would make a backup of flows.json though, before you remove anything.

Good idea! But… I searched the whole node-red directory and found nothing.
I suppose it must be some component called by NR that’s doing this

I don’t use hassio, is that a hassio docker network IP address? it comes up very often on a google search, related to Home Assistant.

I was getting this same error and this one fixed it for me, thank you!

1 Like