Node Red becomes somewhat unresponsive!

I use Node Red as an Add-on o Home Assistant and I used Node Red for some of my automations.

Recently (not sure if it coincided with update to Home Assistant or to Node-Red) I noticed that when I opened Node-Red in Home Assistant some of the status-information below the nodes (Like next trigger time, running etc) were missing.

I also noted that the push-button on the left of the inject node was greyed out and couldn’t be pressed.

I tried restarting Home Assistant, I tried to restart Node-Red and I even tried uninstalling and re-installing Node-Red but nothing helped.

I then started going a bit more methodology about this and in the following I use the inject node and whether the button in that node is “toggle able” as criteria for whether Node Red is running or not.

I saved each of my flows and then uninstalled Node-Red; deleted everything in the Node Red folder in the addon_configs folder.

Then I reinstalled Node Red. I loaded back my flows and I got staus information for the node back and the inject button was OK (i.e I could toggle it)

So far so good but if I select a dashboard in Home Assistant (and thus move away from Node Red) and them back in to Node Red the node-status was gone and I could no longer toggle the inject button.

Then repeat. Uninstall Node Red and clear the folder and reinstall Node Red.

I then created a small flow with just an inject not and a debug node; it worked! Selecting a different dashboard and back into Node Red it still worked.

I then imported just one my flows (not all of them). As soon as I moved out of and back into Node Red the inject button was unresponsive.

Then repeat again.

Started with the simple flow of an inject and debug node. All good. Then creating a new flow with another inject and debug node. Still good and still good when going out and back into Node Red.

Then loading one of my flows (not the same as above) and as soon as I go out and back into Node Red inject node is again unresponsive.

Noting in the log files indicate anything is wrong.

As for versions - I’m on Node Red 17.0.8 and Home Assistant 2024.3.0 and both run on a Raspberry Pi 4 with 8G of memory.

Does anyone have any ideas, suggestions and recommendations ?

In the side panel, select home assistant. Is there only one server defined?


Is this what you are referring to? If so - yes

When you double click on it, is “I’m using the home assistant addon” checked?

e. If it is, did you add any nodes from the palette manager? uninstall them. If not disable all deployed flows. Drag out an inject and debug, deploy. Leave and come back, is it working still? No? use your HA ip with 1880 instead of 8123.

If it works enable flows one by one, leaving and returning after each deploy. A bad flow can cause this problem.

To first answer your questions…
“I’m using the home assistant addon” is checked.

I have been using a few nodes from the palette manager; currently the only one that I’m using is eztimer and it’s been running for a while.

Now the interesting part.
I read your suggestion on port as to change the port in Node Red Configuration which I did. It didn’t work but when I realized that this was properly not what you meant I reset that back to default and things appeared to work.
Just to make sure I deleted all flows and then imported them back into Node Red.
Because it was a “clean” Node Red eztimer was not installed so Node Red obviously complained. Rather than installing eztimer I deleted the “inactive” entire nodes and while some of the flows would be useless the inject button in all flows (including those that does not use eztimer) became inactive/grey’ed.
I then once more deleted all flows, installed ez-timer and then imported all my flows and now it just works! I know I shouldn’t jinx it but I’ve gone in and out of Node Red a couple of times and it still works!

Your comment on the port though triggered a faint memory related to issues with Zigbee2MQTT and Node Red running on the same server. I did do a quick search, found nothing and could be completely mistaken but I did switch from ZHA to Zigbee2MQTT one or two month ago…hmmm

Anyway - things appear to be working now. Thank you so much for your help @Mikefila