Node-Red Broken after Restart of HA " Simple Restart "Home assistant connection failed with error:""

I’m starting a new thread on this as it seems like it is a common problem across the community that just appeared over the last couple days.

After a restart of HA Node-Red stopped working the Node-Red add-on from HASSIO is having issues connecting to HA.

I’ve tried almost every variation including: http://hassio/homeassistant, ip-address, duckdns address, with port without, https, http. No dice.

“Home assistant connection failed with error: Connection to home assistant could not be established with config: http://hassio/homeassistant

@ZStanard there are several other threads on this issue that you may want to look at. Others are experiencing similar problems. Just search for node-red and they should come up.

Not that this is the answer, but I had the same issue…when I used the IP address. Since I did not have anything relevant in my Node Red application, I deleted everything completely that was pointing to the IP of my HA…and then I created a new one as you described above and as I show here…and all my connection errors went away. Not saying this is the perfect answer, but it worked for me. And my debug is devoid of errors now.