Node-RED Companion Connection Fails With Public SSL

I recently upgraded my HA and NR container. Afterwards, every node from node-red-contrib-home-assistant-websocket stopped working with the message:

This node requires Node-RED custom integration version 1.0.4+

Node-RED Companion showed no entities, and the debug info from within NR components failed with:

Call-Service attempted without connection to server.

Searching this forum, every post I found said you need to follow the instructions, which I did a half dozen times. Nothing. I finally scrapped my whole setup and tried it from scratch. Again, nothing.

My setup uses a public URL with SSL to be accessed internally and externally. It’s the only warning message in the HA log:

2023-11-07 18:13:05.978 WARNING (MainThread) [homeassistant.components.ssdp] Could not set up UPnP/SSDP server, as a presentation URL could not be determined; Please configure your internal URL in the Home Assistant general configuration

I finally pointed the server config to the internal IP and told it to ignore the SSL, and bob’s your uncle.


I can also use public URL if I tell it to accept the cert without validation:

This has been a very frustrating process. I love the features that NR offers, but it’s brittle with ambiguous error messages. I hope that doesn’t come across as too harsh. I appreciate the people who made this. And I will continue to use and support it financially in the future.

thanks, this is great info. I have been fighting this for a while and did not realize where the problem was. Checking “Accept Unauthorized SSL Certificates” fixed it…