Node-red-contrib-sonos-plus configuration node issue

Router: Tplink Archer a7 (AC1750)
Home Assistant version:
Node Red:v2.2.0
Node: JS:v16.13.2

I created a fresh installation of Home Assistant/Node Red. Subsequently I installed the “node-red-contrib-sonos-plus” nodes from the Node Red Palette. Prior to this installation I created a “reserved” IP4 address for the “coordinator.” My coordinator is the one speaker in my Sonos system connected to the router via ethernet.

90% of the time on system start up the upstream connection to coordinator (Ethernet connected sonos speaker) fails and I get a failure to connect message


10% of the time the plugin successfully connects upstream to the coordinator and the plugins nodes work normally

Note: My TP link Archer A7 router does not offer Static IP. I also do not have DDNS capability.

Why is my connection success rate “intermittent”, instead of “success/fail”? why is it so low? How do I improve the connection percentage to an acceptable level? Do I need a better router that can do a static iP instead of a reserved IP, Do I need DDNS, what an I missing???

Logs below

Welcome to Node-RED
2 Feb 10:50:06 - [info] Node-RED version: v2.2.0
2 Feb 10:50:06 - [info] Node.js  version: v16.13.2
2 Feb 10:50:06 - [info] Linux 5.10.63-v8 arm64 LE
2 Feb 10:50:08 - [info] Loading palette nodes
2 Feb 10:50:17 - [info] Dashboard version 3.1.5 started at /endpoint/ui
2 Feb 10:50:18 - [info] Settings file  : /etc/node-red/config.js
2 Feb 10:50:18 - [info] Context store  : 'default' [module=memory]
2 Feb 10:50:18 - [info] User directory : /config/node-red/
2 Feb 10:50:18 - [warn] Projects disabled : editorTheme.projects.enabled=false
2 Feb 10:50:18 - [info] Flows file     : /config/node-red/flows.json
2 Feb 10:50:18 - [info] Server now running at
2 Feb 10:50:18 - [info] Starting flows
2 Feb 10:50:18 - [error] [sonos-universal:f51aee9d8314e0ba] create and subscribe: serial number/ipv4//DNS name are invalid :: Details: none
[10:50:19] INFO: Starting NGinx...
2 Feb 10:50:23 - [info] [server:Home Assistant] Connecting to http://supervisor/core
2 Feb 10:50:24 - [info] [server:Home Assistant] Connected to http://supervisor/core



According to the manual (Chapter 15, paragraph 3) for you router, it does support reserving a static IP. That may help.

Thanks for the response

I am considering multiple root causes for the poor performance at the moment… I’m not that knowledgeable, but I am persistent and polite . :slight_smile:

1)Applicable Red Node and ancillary Sonos documentation points to “greatly preferred” Static IP, and shows a greatly preferred for a DDNS capability down to the device level. To make the Sonos Plugin achieve maximum performance , should I changeout my router to a more robust unit? if so, which reasonably priced router has well thought out static and DDNS capabilities?

  1. I use an IP4 address. The installations I saw on youtube used a host name instead of the IP4 address. Does this make a performance difference?



Hi Craig.

The messages says that the entered ipv4 address has the wrong syntax → Please don’t enter any Ports - in this case 8123.

As this port is usually used for Home Assistant I guess that this is not the address of any SONOS-Player.

Option 1: leave the ip address totally empty (not even blank character), use the field serial and push the lens button and select your player (it copies the serial number of the sonos player into the field serial)

Option 2: If you are sure that you did assign a static address to your SONOS-Player then you can
use the original player name field, push the lens button and select your player (it copies the ipv4 address into the field playername)

Let me know if that works. Can you point me to the youtube video?

You don’t need DDNS. Static IP address just means that you assign a fixed ipv4 address to the SONOS player in your local network and every time the router or the SONOS reboots, the SONOS gets the same address. You can look that up in your router and verify it.
You dont have to worry about performance ipv4 such as versus DNS such as