Node red fails

Hallo all,
When I start node red I get the message bad gateway 502
After pressing Node-Red a few times in the menu, it starts up partially. The bar will go half way and stop loading.
Sometimes after pressing again I get the screens. After a change, Deploy also displays the following message:
Deplay failles, bad gateway 502. After the 2nd press, the page will be saved.
Anyone have an idea what the cause is and how to fix it?


Try clearing the browser cache, also try using direct access if your not already (yourHAip:1880)

Thanks for the reply. // gives cannot connect to server

I cleared the cach. Same result: bad gateway 502
Ik tryed in safari-chrome an firefox all the same result // gives cannot connect to server

Do your Configuration settings look something like this ?

Any errors in the log ?

The strange thing is that it worked fine for several months. At some point I installed dimmer setup:

From that moment it went wrong. I have removed the flow again but I can no longer start on node red.

My configuration:

certfile: fullchain.pem
credential_secret: xxxx
password: xxxx
username: xxxx
password: ''
username: ''
init_commands: []
keyfile: privkey.pem
npm_packages: []
ssl: false
system_packages: []
theme: default


Now it gives:

502 Bad Gateway


I think I’ve found the cause. Something probably went wrong when installing the link in my last post. I now see 3 times Philips Hue in the flows that were automatically added during installation. I have now removed 2 of them…
After that node red started 3 times, and 3 times successfully. I hope he stays stable now.
Thanks a lot for the support.