Node-Red file node not writing to file

I recently moved my Home Assistant to the Intel NUC- very pleased with the results.
I am running into a problem with the Node-Red file node.

I want to use Node-Red to write sensor data to a file. This flow works in NR on the Raspberry Pi (with the appropriate path), but not on Node-Red installed via Home Assistant on the Intel NUC.

The one and only error message I got was:
Error: ENOENT: no such file or directory, write ‘/home/steve/Documents/Garden/mytest.txt’
Note- I never saw this error again.

Does anyone have a tip where I should be writing my file?

The Node-RED add-on is a Docker container and can’t “see” the host file system. You could use /share, which is mapped to /usr/share/hassio/share in the host.


I am completely confused about the files in a docker container.

I tried /share/myFilename in the flows, and. It worked.

Which may explain another problem I had a few weeks ago when I tried to make a Samba share to a folder on my home: /home/steve/share, and I was confused because even though I could do a net use from another PC, nothing I wrote into /mnt/share was in the shared folder… I planned to troubleshoot that at a later date. But, you may have provided the solution to why I can’t share my /home/steve/share folder. When I mapped to \nuc\share on my PC, there was my log file. (But nothing in my /home/steve/share folder.).

Thanks Mauricio.
Is there any other file or device gotchas waiting for me in Docker? Where can I find the documentation about the /share folder?

1 Like

There are no gotchas, you just need to be aware of which and where folders are mapped in this case.

Thanks Mauricio! You make my day!

Hi, I have the same issue with trying to add a path on read file node. What was exactly the solution? “Error: ENOENT: no such file or directory, open ‘C:\Users\Γιάννης Μοσχολιός\Desktop\Test.csv’” Mine error looks like this. Mauricio gave a solution with /share. Can you help me with the path?

Home Assistant OS allows access to the config/www folder. I also have the Samba Share Add-On installed which means you can also see the config/www folder from Windows. In my File Write node I have this path: /config/www/XML_tags.htx when creating my XML_tags.htx file. I’m then able to use a Windows Task Schedule on my Windows server to move the file from my Home Assistant hardware to the Windows network server.

1 Like