Node Red- How to change password?

If this looks like DeJaVu, it is.
How do I change the password in Node-Red?

Not sure which password you are talking about, or how you have NR installed so I might be pointing you in the wrong direction, but If it’s via the add-on the password is set in the config of the add-on.

I added it through the Add-on store. There is no configuration.
The “Auth” badge says: “An add-on can authenticate users against Home Assistant, allowing add-ons to give users the possibility to log into applications running inside add-ons, using their Home Assistant username/password. This badge indicates if the add-on author requests this capability.

If I read this correctly, then the Node Red login and password are the same as the Home Assistant credentials.

If this is true, then this is rather inconvenient. I want to control my own login credentials. To be honest, I would rather not need to log in to Node Red separate from Home Assistant.

If you click on Node Red in the addon store, then click on the configuration tab at the top there are some options for passwords to protect access to some types of nodes. See for details. When are you seeing the request for the password? If i open the webui from Home Assistant I don’t get asked for a password, so there must be something different in our configurations, we just need to work out where!

As @GordonTGopher stated there is a config tab in most addons. If configuring via mobile the tab is on the bottom instead of the top…just an fyi.

I get asked for the login and password when I click on Node-Red on the sidebar.

I never tried opening it form the config tab, but that doesn’t require a login.

How did you add it to the sidebar?

This is in my configuration.yaml from long ago:

    title: Node-RED
    icon: mdi:sitemap

Try removing that entry from your config.yaml and clicking the “show of sidebar” option on the Node Red add-on to get it added that way.

:point_up_2: What @GordonTGopher said.

That seems to have fixed it. As I said, the configuration.yaml was years old and when I moved my Home Assistant to an Intel Nuc running Ubuntu, and reinstalled Node Red.

Pleased you got it sorted.