Node-Red in Docker gives error

Today I have spent my day installing on an Intel NUC with the help of Docker. Everything went fine (only a big struggle with my Z-wave stick), and my first nodes are running again. I was a former Domoticz user but decided to move to Home Assistant.

Because I am not really into coding I decided to install Node-Red inside I have got it running in a docker (no errors there) and I can start it inside

The problem is that I got this message when I tried to build something in the editor. Cannot find what I have done wrong.

Hopefully somebody can help me with this.

Have you pressed the red deploy button right top after setting up the server (homeassistant) in nodered?

Yes I did, the button is ‘grey’ now. I can choose ‘restart flow’ which gives a successful answer.
I put an event on the board and below it it says ‘conected’. When I click on it I get the same message again…

If you are using, then you can use the addon for nodered. Is that what you have done? It seems that node-red can’t “talk” to HA.

In NR you have to have this server node where you describe how the two tools will connect.

This is, in node-red, where to configure the link between NR and HA. If you don’t use the add-on, you will have to unselect the “I use the Home…” and configure manually the access token and base url.

In a nutshell, if you use hassio, go for the addon !


I am unsing the add-on and it runs but i still get these error messages. Where can I find edit server node? Cannot find it in the add-on?

Sorry, found it, settings are same as yours only ‘Home Assistant’ where you have ‘hassio’

But does not change anything.

So, go in the node-red addon configuration in hassio. Click restart and look at the debug. It should tell you things…

I do not say many errors there:

[s6-init] making user provided files available at /var/run/s6/etc…exited 0.
[s6-init] ensuring user provided files have correct perms…exited 0.
[fix-attrs.d] applying ownership & permissions fixes…
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts…
[cont-init.d] executing…

Add-on: Node-RED
Flow-based programming for the Internet of Things

Add-on version: 6.1.4
You are running the latest version of this add-on.
System: Ubuntu 18.04.4 LTS (amd64 / intel-nuc)
Home Assistant Core: 0.107.7
Home Assistant Supervisor: 209

Please, share the above information when looking for help
or support in, e.g., GitHub, forums or the Discord chat.

[cont-init.d] exited 0.
[cont-init.d] executing…
[cont-init.d] exited 0.
[cont-init.d] executing…
[cont-init.d] exited 0.
[cont-init.d] executing…
patching file nodes/ui_base.html
Hunk #1 succeeded at 1243 (offset 712 lines).

It stops here ?
Normally you should have extra lines such as:

[cont-init.d] exited 0.
[cont-init.d] executing... 
[cont-init.d] exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[15:03:30] INFO: Starting Node-RED...

> addon-node-red@ start /opt
> node $NODE_OPTIONS node_modules/node-red/red.js "--settings" "/etc/node-red/config.js"

29 Mar 15:03:31 - [info] 

Welcome to Node-RED

29 Mar 15:03:31 - [info] Node-RED version: v1.0.4
29 Mar 15:03:31 - [info] Node.js  version: v12.15.0
29 Mar 15:03:31 - [info] Linux 4.9.0-3-amd64 x64 LE
29 Mar 15:03:31 - [info] Loading palette nodes

Can you uninstall NR, restart hassio, and reinstall NR. Maybe, something went wrong during the first install…

Can you also copy your node-red config here (remove the secret…)?


I have Node-red running for around a year… never issues. It was the latest update that broke things and I have updated successfully many times before.

Uninstall NR also means to loose all flows etc… Since I only automate via NR that’s not an option…

Sorry, I thought I was responding to this: