Home Assistant Community

Node red not showing GUI

#1

EDIT 2: clearing the browser cache fixed the problem … Woops!

EDIT 1: appears to be a problem with V3.0 addon. See issue at https://github.com/hassio-addons/addon-node-red/issues/197.

After restarting, Node-red won’t show the graphical editor anymore (just the banner):

image

It used to work just fine, and I created successfully a few flows.

Restarting (from the hass add-on panel) shows a “normal” log:

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 00-banner.sh: executing... 

-----------------------------------------------------------
 Hass.io Add-on: Node-RED
 Flow-based programming for the Internet of Things
-----------------------------------------------------------
 Add-on version: 3.0.0
 You are running the latest version of this add-on.
 System: Ubuntu 18.04.2 LTS  (amd64 / qemux86-64)
 Home Assistant version: 0.91.3
 Supervisor version: 160
-----------------------------------------------------------
 Please, share the above information when looking for help
 or support in, e.g., GitHub, forums or the Discord chat.
-----------------------------------------------------------
[cont-init.d] 00-banner.sh: exited 0.
[cont-init.d] 01-log-level.sh: executing... 
Log level is set to INFO
[cont-init.d] 01-log-level.sh: exited 0.
[cont-init.d] nginx.sh: executing... 
...

followed by state updates (that it get’s just fine from hass).

What’s the best way to diagnose this (other than getting help from an expert)?
Also, where do I access the complete log (in the add-on screen the top of the log just scrolls off).

#2

Are you accessing it through an iframe? If so the latest version was updated with ingress. Go to the addon in the hass.io page and open it from there and it should work.

#3

Clearing the browser cache was all that’s needed. Embarrassing.

Thanks!

#4

Same here. Purging the cache fixed it.

#5

This only fixes it until the next time though - there is a load of bug reports on the node-red added github … check it out https://github.com/hassio-addons/addon-node-red/issues

All showing the same thing - all having major problems over the past 5 days or so.

#6

Just confirmed it again … cleared browser cache… logged in fine. Reloaded… same error.

#8

I have been having the same issue.

Just as I started typing this I noticed Node Red have release 3.0.2 update in home assistant which the update log says it is about addressing this very issue we are having.