Node red not starting on home assistant

I am trying to setup NodeRed on Home Assistant.

I have been running Mosquitto MQTT on Home Assistant for over a year.

I am configuring NodeRed with a credential secret
For http_node and http_static I have entered the user name and password used with Mosquitto MQTT
I have turned off ssl
everything else has been left to its default.

When I click on ‘Start’ NodeRed does not start.

There are multiple entries in the log that say
13 Sep 17:40:16 - [info] [mqtt-broker:MQTT] Connection failed to broker: mqtt://localhost:1883

would appreciate knowing what I am doing wrong.

These settings are not MQTT related. Try removing them and restart. Is this a bare install? NR doesn’t require MQTT to operate unless you want to use those specific nodes.

Yes, it is a bare (first time) install.

actually, with no other changes than perhaps several reboots of HA it (NR) suddenly started running - however the

[mqtt-broker:MQTT Connection failed to broker: mqtt://localhost:1883

log entries are still there.

I do want to use MQTT in my NR implementation.

Hmmm, I added an NR Flow that makes use of MQTT and the flow, including the MQTTT publish, worked. I tooked a look at the log, and after I ran my first publish the message about the MQTT Connection failing stopped appearing. I rebooted HA and it is all still working just fine.

Looks like all I needed to do was multiple reboots to get it going?

In any case, thanks for your help.

Strange - but glad you got it working.