Node Red on Windows 10 PC (Used a 2nd Pi instead)

I’m using alexa with Node Red, and been finding more uses for this combination, but it seems to be slowing down.

I have Node Red and HA running an a Pi3 right now.

I also have a windows 10 PC for running Blue Iris (security video cam recording program), and that PC is running at around 25-30%. I record everything, so this PC runs 24/7 already.

So I’m thinking about moving Node Red over to this PC. Found the windows 10 NR installation instructions, and seems simple enough. Hopefully I can get NR on this PC to talk to HA ok.

I had thought about buying an upgrade to my pi, but since I already have this PC with some bandwidth, seems like a better solution.

Any reason not to do this? Any hints to make it easier?


I have no idea about Node-Red on a win10 PC … but I have installed Node-Red on a dedicated RPi and the performance and response time is just incredible. I measured the CPU usage over the last 2 weeks and it never went over 8% utilization.

I think a Win10 has just too much overhead. My Node-Red RPi is now sitting next to my router (which is providing the power via the USB port) and I can easily access via SSH.

I was trying to brute force it with my PC, but maybe not.
It was easy to install node red on a pc using instructions from the node red site, and to start node red.
But I can’t install the home assistant palette I need. It says it can’t find git, and I tried to install git for windows but it’s still complaining.

So I think I will try to run node red on a separate pi, I have another one, and see how that goes. Thanks for the input.


I run everything on a Windows PC under Ubuntu VirtualBox and it works really well. I now have about 13 docker containers including HA, and Node-Red. One of the main benefits is to be able to easily backup everything with a single snapshot of the VM. The main disadvantage is that VirtualBox doesn’t run as a Windows Service, which is a pain, but not insurmountable.

So I am trying on another pi, have node red running and managed to install node-red-contrib-home-assistant

But now my problem is I can’t connect to home assistant. Put in the HA pi’s adds and PW, but no joy :frowning:

This does seem faster now, NR starts a lot faster running on another pi, but that doesn’t help since I can’t get NR to talk to HA.

I’m using the to access my HA from NR … I had duckdns installed earlier and had to use instead.

After setting-up the HA node in NR it is necessary to reboot the NR pi to get the settings updated properly.

What error message are you getting in NR debug window ?

error is the dreaded
"Home assistant connection failed with error: Connection to home assistant could not be established with config:

I’ve rebooted both pi’s, multiple times now lol

Usually it shows the http used by the HA node :thinking:

there are 2 node-red npm for HA … i don’t use the ‘websocket’ version.

I think there was an issue when I did the NR install the first time … it was not able to install the HA nodes properly … I had to install ‘git’ on the pi ( i think it was >> sudo apt-get install git) than I had to re-install the HA-node.

I’m currently not home but have prepared a step-by-step install of NR which is working for me … will share later (!2h)

I think I had an extra / at the end of 8123. Deleted that and it works!!

I had to restart NR to stop the error messages, but I have a connection now (biggest worry), and I tried a couple binary sensors and I can read them.

Now to copy my flows over to the other pi

Thanks for the help

:+1: good luck … I migrated mine via export-all and import-all … just ensure you have all your nodes loaded before import…this way most of your settings will be taken over and failures are minimised

So I went to hassio/config/node-red with samba to get my node-red files.
package.json has a list of the palettes I installed and I installed them.
copied over my flows.json file with scp, have to rename it to add raspberry to it, something like that. There will be a small one there if you played with NR before doing this.

All my flows copied, but I did have to setup the home assistant server connection again, as it copied over the one from hass-io, and needed to change for a separate pi. Just remember to NOT have a “/” after 8123. Then I had to double click on all the places I used a call to HA for NR to fix them.

Also had to forget and re-find some alexa skills, but now most of my flows are working.

And they are MUCH faster. I did this because of lag when I asked alexa to do something, and that lag is gone. I can’t imagine it can be much faster. And if I add enough to NR to slow it down, it would be easier at this point to migrate to something faster. But for now I’m very happy I decided to do this. For the cost of a pi, it really improves NR usability if you have flows where you need real time responses.

Oh if you do this, I HIGHLY recommend to make sure you can connect from NR to HA first, before you import your HA flows into NR. I just dragged in a events state box, and configured for a binary sensor that I could easily change, to make it easy to test.
Even after you connect, I got error messages until I stopped and restarted NR. But is easy now to do that. And also REALLY fast to restart, compared to running in hassio.