Node Red v1.0

Any one upgraded to Node Red version 1 yet?

I have it in a docker compose on a NUC not Hassio as:-

image: nodered/node-red-docker:v8

And not sure if this is right in new version:-

image: nodered/node-red

Yes and yes.

I upgraded a day or two ago, and so far no issues. To be fair though I don’t have a large amount of automation.

I was previously on nodered/node-red-docker:v10 so I already was on v10 which is what the latest is running. I don’t think going from v8 to v10 would cause you any issues though - but I am no expert.


Thanks I tried V10 but it lost all my flows so went back to v8.

Luckily I exported all my flows first.

That is very concerning!
Glad you had a backup.
Not sure why that would have happened, but I don’t know much about it.


Upgraded on day 1 using the nodered/node-red:latest-10 image. I have about 95% of my automations in there and have not had a single issue yet.

And definitely backup first!

I’m upgrading to v1.0 right now - I use git version control for my flows so I can restore them if needed. Thanks for the heads up.

I too have Node Red running under Docker on a NUC (not the add-on). I have upgraded about 10 instances, one of which connects to HA. All suffered the same two minor problems:

  • Some nodes have been moved to (I assume) separate repositories. For me, suncalc and email disappeared and flows won’t run until you fix the problem. It’s a simple matter of adding them back in via the palette.

  • Lots of permission problems accessing files. This has something to do with the user that created the folder vs the user NR is now running under. I fixed them by sudo chmod +R 777 /the/folder, which is probably overkill.

Other than these minor issues, all good. I also took the opportunity to change to running a specific version rather than the default of ‘latest’ (ie. nodered/node-red:1.0.0). I’m planning on setting up a notification for changes to major/minor version and this seems like an easy way to go (and I hate ‘latest’).

1 Like

Well I went for it and installed v1 and it failed on this.

4 Oct 13:21:34 - [warn] [node-red-contrib-rfxcom/rfxcom] Error: The module '/data/node_modules/node-red-contrib-rfxcom/node_modules/serialport/build/Release/serialport.node'
was compiled against a different Node.js version using
NODE_MODULE_VERSION 57. This version of Node.js requires
NODE_MODULE_VERSION 64. Please try re-compiling or re-installing
the module (for instance, using `npm rebuild` or `npm install`).
4 Oct 13:21:34 - [warn] ------------------------------------------------------

Not sure what to do now.
Any Help Please.

The error is for the module node-red-contrib-rfxcom.
I would check if there is an updated version of this module that uses an updated node.js version.
Alternatively remove this module, upgrade, and then reinstall it - I expect this could work too.

Either way, the error is telling you that the rfxcom module is the issue.


Yes thanks i have tried to remove the module and its at its lastest. So i think the module needs to be updated to NODE_MODULE_VERSION 64. So may have to wait for the maintainer of the module to update it.

Edit I Have gone back to Node Red 0.20.8 and all back to normal.

It may be worth asking over at the NodeRED forum, there may already be a fix. :slight_smile:

1 Like