Node Red V17.0.0 Issues after Update

I replaced a node this morning with a new plug, and now I get this when deploying. Everything seems to work fine, but now the node has a warning on the label as well.

image

image

image

17.0.0 is a major update, so read the docs on the new version.
I don’t use NR, (shudder), but when the first number resets and the minor numbers are 0, big things happened.

Yep, update broke all of my Lutron Pico Remotes.

Now I have to set aside time to troubleshoot

Same thing here. I’ve restored nodered to 16 and all is ok again. I’ll wait and see now.
It’s a simple “call service” to trigger a nodered switch… doesn’t need any extra data.

So I found my issue. Turns out the actual HA “node” in the NR palette was almost hilariously out of date.

I didn’t realize the palette nodes didn’t update along with NR. Updated and my issue went away.

2 Likes

17.0.0 is a major update, so read the docs on the new version.

Hi All

My UI doesn´t start up at all after the update. The release note only states:

This release upgrades to Alpine Linux 3.19.

If you use the system_packages or init_commands configuration option, there is a small possibility you need to adjust to this change.

Thus, what are those ‘adjustments’? Would someone please explain, what kind of work is needed to be able to work further?

This is the protocol:

s6-rc: info: service s6rc-oneshot-runner: starting
s6-rc: info: service s6rc-oneshot-runner successfully started
s6-rc: info: service base-addon-banner: starting

-----------------------------------------------------------
 Add-on: Node-RED
 Flow-based programming for the Internet of Things
-----------------------------------------------------------
 Add-on version: 17.0.0
 You are running the latest version of this add-on.
 System: Home Assistant OS 11.3  (amd64 / qemux86-64)
 Home Assistant Core: 2024.1.2
 Home Assistant Supervisor: 2023.12.0
-----------------------------------------------------------
 Please, share the above information when looking for help
 or support in, e.g., GitHub, forums or the Discord chat.
-----------------------------------------------------------
s6-rc: info: service base-addon-banner successfully started
s6-rc: info: service fix-attrs: starting
s6-rc: info: service base-addon-log-level: starting
s6-rc: info: service fix-attrs successfully started
s6-rc: info: service base-addon-log-level successfully started
s6-rc: info: service legacy-cont-init: starting
s6-rc: info: service legacy-cont-init successfully started
s6-rc: info: service init-nginx: starting
s6-rc: info: service init-customizations: starting
s6-rc: info: service init-customizations successfully started
s6-rc: info: service init-nodered: starting
s6-rc: info: service init-nginx successfully started

up to date, audited 156 packages in 1s

17 packages are looking for funding
  run `npm fund` for details

found 0 vulnerabilities
npm notice 
npm notice New patch version of npm available! 10.2.3 -> 10.2.5
npm notice Changelog: <https://github.com/npm/cli/releases/tag/v10.2.5>
npm notice Run `npm install -g [email protected]` to update!
npm notice 
s6-rc: info: service init-nodered successfully started
s6-rc: info: service nodered: starting
s6-rc: info: service nodered successfully started
s6-rc: info: service nginx: starting
s6-rc: info: service nginx successfully started
s6-rc: info: service legacy-services: starting
[01:20:47] INFO: Starting Node-RED...
s6-rc: info: service legacy-services successfully started

> start
> node $NODE_OPTIONS node_modules/node-red/red.js --settings /etc/node-red/config.js

9 Jan 01:20:49 - [info] 

Welcome to Node-RED
===================

9 Jan 01:20:49 - [info] Node-RED version: v3.1.3
9 Jan 01:20:49 - [info] Node.js  version: v18.19.0
9 Jan 01:20:49 - [info] Linux 6.1.70-haos x64 LE
9 Jan 01:20:49 - [info] Loading palette nodes
9 Jan 01:20:51 - [info] Dashboard version 3.6.2 started at /endpoint/ui
9 Jan 01:20:52 - [info] Settings file  : /etc/node-red/config.js
9 Jan 01:20:52 - [info] Context store  : 'memoryOnly' [module=memory]
9 Jan 01:20:52 - [info] Context store  : 'file' [module=localfilesystem]
9 Jan 01:20:52 - [info] User directory : /config/
9 Jan 01:20:52 - [warn] Projects disabled : editorTheme.projects.enabled=false
9 Jan 01:20:52 - [info] Flows file     : /config/flows.json
9 Jan 01:20:52 - [info] Server now running at http://127.0.0.1:46836/
[01:20:52] INFO: Starting NGinx...
9 Jan 01:20:52 - [info] Starting flows
9 Jan 01:20:53 - [info] Started flows
(node:315) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 runtime-event listeners added to [EventEmitter]. Use emitter.setMaxListeners() to increase limit
(Use `node --trace-warnings ...` to show where the warning was created)
9 Jan 01:20:53 - [info] [server:Home Assistant] Connecting to http://supervisor/core
9 Jan 01:20:53 - [info] [mqtt-broker:MQTT Server] Connected to broker: NODERED-MQTT@mqtt://localhost:1883
9 Jan 01:20:53 - [info] [server:Home Assistant] Connected to http://supervisor/core

I have to admit, as long Node Red worked (and it did until 17.0.0) I didn´t check the protocol, thus, I cannot tell what is new in there or what is missing…

Thank you

Yeah that worked… thanks.

Hi all,

Version 17.0.1 is working again.

After the disastrous 16.x update, I am so reluctant and terrified to upgrade. I want to make absolutely sure that this isn’t going to crash my flows before I update