Home Assistant Community

Node Red will not connect with hassio

#21

I’m having the same issue. Was working so well and then just randomly just stopped last night. It’s worth noting that I’m using the community version of the addon, found here not the notoriousbdg one some of you noted. It seems like there’s a bug currently logged here which looks like it might be related but… not sure.

Really hoping this comes back soon, I’ve spent quite a bit of work on ironing out all my automation flows recently.

0 Likes

#22

I’m having the same issue. I’m running hass.io 0.72.1 and didn’t do any config change or software update in the last 2 weeks, but suddenly this morning my Node-Red automations stopped working. I’ve tried all combinations of URL and ports I could imagine, but only the external URL for HASS worked, as markomannux mentioned. Luckly I had hairpin NAT already configured, so this saved my day. Thanks marko! Still curious what’s the issue…

1 Like

#23

yes, same here … suddenly having this issue since this evening without any changes to any config

it happened after a reboot the first time

I just did a complete new install of node-red and the issue is happening as soon I’m adding a flow for xiaomi or kodi… a simple inject and debug was working

0 Likes

#24

It looks like the issue is with the home assistant proxy.

You can do a workaround by adding your home assistant IP and port to the node instead of http://hassio/homeassistant (http://192.168.1.112:8123)

If you use https like duckdns you’ll need to use your duckdns url https://yourduckdnsurl.duckdns.org:8123

1 Like

#25

I will try and respond… but having the traffic via internet is not a good idea

0 Likes

#26

Any hint on why the home assistant proxy suddenly stopped working? I did not update anything…

0 Likes

#28

Is not going through internet, just to your router and back to your LAN. You have to have hairpin NAT configured or doesn’t work at all.

0 Likes

#29

No idea, that’s not really my area of expertise. I was hoping Franck might shed some light on that one.

0 Likes

#30

Hey, you might want to redact that error, I’m guessing that’s your public IP address.

0 Likes

#31

I’ve experimented with several variations, and, same as xx_Nexus_xx, can’t get anything to work.

0 Likes

#32

I’m going to try installing this version (though I see below that that one is broken too ATM):

0 Likes

#34

Got it working (I think) with the replacement of my connection string to my ducks external address. When I say “I think” that’s because periodically it seems to lose the connection to my HASSIO. Automation’s see to be working for now but as someone else noticed this my notoriousbdg version has been deprecated. Having to rely on the internet being up is a little disconcerting and would rather use the previously working http://hassio/homeassistant connection path

0 Likes

#35

The workaround, using the HA IP and port fixed the issue for me. However, the error messages continue to show up.

0 Likes

#36

I tried the HA IP and port as well but it did not work. I tried the DUCKDNS URL as well without luck :frowning: … how / where did you apply your workarounds and did you do anything else?

Is this a Node-Red issue or a HA issue? … ever since I’m having this issue my HUE lamps as well , they are “UNAVAILABLE” too

0 Likes

#37

I applied the IP and port in one of the HA nodes, under Server, click on the edit button, then the Base URL.

The other thing I also noticed is the load, 1 minute and 5 minute, increased substantially with node red running, goes from the typical 0.5 to as high as 3. I stopped node red and the load went back to normal, 0.5.

As I mentioned above, I stopped node red, then I hit Rebuild, restarted. Changed the Base URL back to http://hassio/homeassistant, everything is working normally again. Try it and see if that fixes it.

0 Likes

#38

There is a node-red update … it sorted my issue

0 Likes

#39

I’m still seeing the same issue after update to Node-Red add-on v0.50 and Hassio 0.74.1.

25 Jul 08:54:02 - [error] [server:Home Assistant] Home assistant connection failed with error: Connection to home assistant could not be established with config: http://hassio/homeassistant <password redacted>

0 Likes

#40

Do a full restart … just in case

0 Likes

#41

Did the update and still didnt work with the http://hassio/homeassistant address, changed my node address to the http://ip:8123 and it works . Although still have the connection errors in node red logs

0 Likes

#42

I migrated from node red under ‎notoriousdbg add on to the one discussed in this string and I think all is well. I first exported all of my flows and then uninstalled the old node red and installed the new node red. I did run into the same problem with http://hassio/homeassistant but after reboot it looks like it’s working. I tried to set up a server using http://hassio/homeassistant with my password but that did not work. The server that was generated by node red with what I think is a derived API key worked. When I imported the old flows the server that was part of that flow had to be deleted and in most cases a restart of node red was necessary to stop the connection errors.

Hope this help.

0 Likes