NodeRed and HomeAssistant with SSL (not

So, I’m running Home Assistant on my Ubuntu server. NOT Hassio since I’m running much more than just home assistant.
I’ve configured it to use ssl with a duckdns address, this all works fine and is addressable from the outside.

Now, I’ve also installed Node-Red (on the same machine) but can’t for the life of me get it to connect with Home Assistant. All guides I could find that contain anything ssl + node-red related are all about Hassio. I’ve also tried this to no avail.

Has anyone been able to configure node-red to connect to an https instance of home assistant that does not run Hassio (which apparently has plugins for node-red)?

I don’t use HassIO and I installed Node Red this weekend. I just configured it using my publicly accessible, off network, address (ie., rather than an internal IP or machine name.

That’s what I did as well (using my duckdns address and self-signed certificate), but I keep getting:

Cannot GET /homeassistant/entities

I feel like I’m missing something obvious…

Any update on this ???

Do we need to use the password too ???

keep getting :

0|node-red | 2 Jun 16:29:56 - [error] [server:Home Assistant] Home assistant connection failed with error: Connection to home assistant could not be established with config:

Did you fix this?

Yes , just include the full base URL of your site with the port 8123 in my case

And yes you do need the password

@carlostico, I too have this problem - still. Please help.
This is my setup:
Home Asistant Core (not v. 0.115.3 running in Docker
NodeRED v. 1.1.3
node-red-contrib-home-assistant-websocket v.0.26.1

The NR <–> HA integration works just fine on my LAN using a HA generated access token.
But when accessing NR remotely (over the internet), the integration fails.
I connect to the NR editor through an Apache Reverse Proxy : and that works just fine. I can access the editor and dashboards.
I have configured the HA integration using both with and without the port 8123 and with bot legacy API password as well as the access token, but all fails.
I don’t think adding the port number makes any sense as that is automatically done by the Reverse Proxy. I assume legacy password is the same as my NR login password?
The only think I can think of, is if NR relies on websocket protocol, perhaps I have to open for websocket through the Reverse Proxy. That’s about the only thing I haven’t tried yet.

In fact, I do not understand why the NR/HA integration should change when I access the NR editor remotely as opposed to locally (LAN) ? After all, both my NR instance as well as my HA instance runs on the same LAN. What I see in my browser is just a view, right (like a looking glass)? Nothing takes place on the remote PC where I run the browser, or… ?