Nodered isn’t starting anymore ever since I switched to Home Assistant yellow

 Add-on: Node-RED
 Flow-based programming for the Internet of Things
 Add-on version: 9.2.1
 There is an update available for this add-on!
 Latest add-on version: 17.0.13
 Please consider upgrading as soon as possible.
 System: Home Assistant OS 12.3  (aarch64 / yellow)
 Home Assistant Core: 2023.9.3
 Home Assistant Supervisor: 2024.06.0
 Please, share the above information when looking for help
 or support in, e.g., GitHub, forums or the Discord chat.
[cont-init.d] exited 0.
[cont-init.d] executing... 
[cont-init.d] exited 0.
[cont-init.d] executing... 
[cont-init.d] exited 0.
[cont-init.d] executing... 
[cont-init.d] exited 0.
[cont-init.d] executing... 
[18:55:55] INFO: Password is NOT in the Have I Been Pwned database! Nice!
[18:55:56] INFO: Password is NOT in the Have I Been Pwned database! Nice!
patch: **** out of memory
[cont-init.d] exited 2.
[cont-finish.d] executing container finish scripts...
[cont-finish.d] executing... 
                Oops! Something went wrong.

 We are so sorry, but something went terribly wrong when
 starting or running this add-on.
 Be sure to check the log above, line by line, for hints.```

I’m seeing “out of memory “but there’s no way this is the reason because I just upgraded and it’s already worked before and only one out of 4 GB memory are currently being used

I switched to Home Assistant yellow

How did you install nodered from a backup of the old system? I think you’ll need to install the addon, then import your flows.

It just got installed automatically when I restored my Home Assistant installation from my old system‘s backup

Update: I installed node red from scratch but now it says my Home Assistant version is too old for it and to be honest, I hate updating because it tends to come with a bunch of unexpected problems

Update 2: now it starts but says the credentials couldn’t be deciphered or something ( in German). what now?

Credential secret maybe? In the addon page config tab there is a credential secret entry. The default is nodered but if you changed it you will need to use whatever it was in the old installation.

I can’t find this tab and to my knowledge I never set credentials like that.

I found another error:

11.6.2024, 09:36:27[node: Home Assistant](http://homeassistant.local:8123/api/hassio_ingress/byuFqtqUn5d9_e4VGODI49cJtpJF_fEbA09KlYUTOGU/#)msg : error

"Error: No credentials provided"

11.6.2024, 09:36:27[node: 53de9085.280ba](http://homeassistant.local:8123/api/hassio_ingress/byuFqtqUn5d9_e4VGODI49cJtpJF_fEbA09KlYUTOGU/#)msg : string[22]

"User Not Authenticated"

That is the connection to home assistant. In a home assistant node, where it says server, is there a server defined? If it is there and If you are using the addon make sure that box is checked.

Otherwise make sure everything is entered correctly. If there isn’t a server create one.

There is a server defined, Home Assistant. Not sure what you mean by “make sure that box is checked”.

Besides, I’ve tried unchecking “Using the Home Assistant Addon” in a Home Assistant node’s server settings and entering an access token manually, just like a newer installation guide said. That didn’t do anything.

What now?

Edit: Fixed the issue by doubleclicking on the specific node that caused the error on the debug-tab on the right side of the screen and checking the box next to “Using the Home Assistant Addon” there.