Non-functional new version of Aqara Door & Windows Sensor T1

Problem with newly purchased Aqara Door & Windows Sensor T1.
I have bought 2 more of these. I already have 22 of them installed and working around the house, but the 2 new ones won’t work.

They pair just fine, with ZHA, but there are no sensors or battery-status, like all the other ones have and the new ones don’t respond or react to anything. (like open/close)

If I look at the zigbee info for the new ones, they are called: lumi.magnet.agl02
Where the old ones are called: lumi.sensor_magnet.aq2

Any suggestions to how I can get these to work as intended?

You did not not mention anything about your enviroment or setup, nor which exact Zigbee Coordinator and firmware that you are using. Can you maybe list or describe installation + products in your setup?

Anyway, the product should work in ZHA if properly paired, see:

Noted that i was suggested to a user that will likely need to first update Zigbee Coordinator firmware, which is usually a good idea regardless. Recommend try upgrading Zigbee Coordinator to the latest community NCP firmware build (not RCP if available for whatever Zigbee Coordinator you are using).

My guess otherwise is that those Zigbee devices probably just failed for you during interviewing when pairing/joining or did not complete the interview process for some reason. Some battery-powered devices can sometimes require multiple pairing/joining attempts before the interview is properly completed. Be sure to perform a factory-reset on the device following the manufacturer’s instructions before try to re-pair/re-join it. For example, a common problem with some troublesome battery-powered devices is that you might need to figure out how “keep it alive” during the whole pairing/joining process (by for example initiating a state change by triggering it, which is normally easy to do on a door/window sensor). Another related tip when having battery-powered devices is to replace the battery with a fresh battery that offers the correct voltage Read the summary of related tips about that here →

Also, if you like many others who did not research how the technology used by Zigbee fundamentally works, perhaps did not take essential preventive measures to avoid EMF/EMI/RMI from the beginning when you setup your installation then the odds are high that you can have issues caused by Electromagnetic interference (EMI, sometimes called radio-frequency interference or RMI, which are usually due to having sources of EMF too close to the Zigbee Coordinator or Zigbee devices), As such the best practice is to first take some basic actions to avoid having sources of EMF/EMI/RMI close to any Zigbee devices and especially the Zigbee Coordinator before even start troubleshooting any further before then re-pairing your devices. Read and follow the related best -practise tips here →

It could also simply be that you do not have enough Zigbee Router devices in your Zigbee network to get good coverage/range in order to reach them via the network mesh, which is needed as Zigbee depends on mesh networking. If you have not already then make sure you add several additional Zigbee Router devices in strategic places/locations to optimize coverage/range. See a summary of related tips about that here →

If those do not work then consider changing WiFi-channel (radio frequency band) on all your Wi-Fi access-points/router if possible, then if that do not make things better one of last optimization you can do (other than adding even more Zigbee Router devices and “known good” high-performance Zigbee Router devices) is to last change the Zigbee channel used by the Zigbee network in ZHA. ZHA integration documentation on how to change Zigbee channel is currently outdated since it can be done via ZHA UI, but there is still valuable information about Zigbee channels here →

For reference, also be aware of ZHA limitations → + information on requesting support for new devices if needed in the future for other products → (note there that the zha-device-handlers repository is for requesting support for Zigbee devices that do not fully expose all expected attributes as entities under the ZHA integration in Home Assistant).

PS: Noticed that you cross-posted the exact same question in Please understand that is the wrong repository to report issues like this with ZHA, see → It is instead better to post in the Home Assistant’s communication channels if you want support with stuff like this → Help - Home Assistant (especially in Home Assistant community forum if need help and/or advice → ). While visiting the Home Assistant community forum I suggest that you check out this community guide which has many more setup optimization recommendations that should preferably be followed before troubleshooting any further → Zigbee networks: how to guide for avoiding interference + optimizing using Zigbee Router devices (repeaters/extenders) to get best possible range and coverage

Sorry, my setup is just a RPi4 with a RaspBee II installed and HA installed directly on the RPi.

I will see about updating the firmware on the RaspBee II. I have not tried that before.

I have more than enough routers in my correct mesh, so I am pretty sure that is not the problem.

As for where to report the issue, I found it very hard to find out where the correct place was, so I just tried something.

I just checked my coordinator, the RaspBee II and from what I can tell it is updated with the lastest version:
Version: 2.25.3
Firmware: 0x26610700

This is the newest stable version: changelog.en
So that cannot be the issue.

Just replaced the battery in the sensor, which is installed in the intended place, just 3 meters from the coordinator.
Tried pairing it several times. Every time with the same result.

A reconfigure shows this (for both new ones, not just the one):

Sometimes the 2 yellow dots go green, but it doesn’t change anything with regards to sensor behavior, as in, it still doesn’t work.

In my bulk purchases, I’ve run into a few bad sensors from Aqara. Same symptoms you’re seeing. I usually just send them back to Amazon and get new ones that work without issue. I have around the same number of door/contact sensors that you do and I think out of the 25 I’ve bought, 3 or 4 were just duds.

I know that doesn’t help the situation, but just sharing my experience with them.

Thanks. I’ll try and return them and see what happens.

FYI, RaspBee can still be a problem for two reasons so my advice is to buy a new adapter regardless:

  1. RaspBee II is outdated hardware (and obsolete for new purchase) so while you might be using the latest released firmware that does not mean that it is new firmware because the RaspBee II as a product is end-of-life and the manufacturer has not been releasing firmware updates for it in several years. So do take note that the latest firmware was released on the 8th of June 2020 (08-Jun-2020) which is almost 4-years ago now:
  1. More importantly, the RaspBee II is an intern Zigbee Coordinator adapter/module which makes it much more susceptible to EMI/RMI/RMF interference compared to using an external Zigbee Coordinator USB adapter connected via a long (and shielded) USB extension cable so you can not get it away from sources of interference. Be sure to at least use wired Ethernet instead of WiFi and move away any USB 3.x devices from the RaspBerry Pi (i.e. use properly shielded USB cables and get those devices away from the Zigbee Coordinator). Again, the Zigbee Coordinator is extremely sensitive toEMI/RMI/RMF interference, so do read and try to follow all tips here:

My recommendation is to buy either “Home Assistant Skyconnect” or “Sonoff ZBDongle-P (by ITead)”:

Just watch this to get a grasp how interference from USB 3.0 is literally killing Zigbee comminication :

and also see whitepaper from Intel on about USB 3.0 radio interference impact on 2.4GHz devices:

  1. No, the latest was release 15-May-2022. I will consider if replacing the coordinator is the best option for me.

  2. I know all this about interference, but I have no USB3 in the house at all and I have no issues with any other Zigbee devices in my network.