None of my smart devices show up in HA

Tags: #<Tag:0x00007f7394245e50>

I recently purchased a Raspberry Pi 4 with 8gb of RAM. I installed Raspbian then docker and then Home Assistant. I created a Nabu Casa account. I’m very new to linux, so that has made it even more difficult. I’m familiar with some very basic commands.

When I first started up, the only device that HA recognized was my printer (I was later able to add my Ring). I tried to integrate my Wiz light bulbs and they weren’t available under integration. Same thing with my Roborock S5Max (not available), my ThinkEco modlets for my AC, and my SmartLife sockets. They’re all WiFi connected and don’t go through a hub.

My Home Assistant UI doesn’t have an add-on option (at least none that I can see).

I tried then to see if maybe I could integrate my Smartthings account to have access to the devices. I went through all the steps and first it said, “Cannot start the smart app.” After I restarted the RPi, it said, “Please wait while the integration is being installed” and then it goes back to the “Setup a New Integration” box without anything happening.

I also tried to integrate my IFTTT and the instructions said that I need to use IFTTT’s “Make a Web Request” but the only option available in IFTTT is “Receive a Web Request.”

If I go to to the “Home Assistant Cloud” both Smartthings and IFTTT appear under webhooks with the proper URLs.

I read that some of these problems might be fixable if I could edit the configuration file but I don’t know how to do that. And since I don’t have the add-on option, I don’t think that I can download an editor.

I then flashed a different SD card and tried to directly boot HASSos. I followed all of the instructions including creating the my-network file on a separate USB.

With HASS – 64bit, I can get as far as the HASS-CLI during installation but don’t know what to do from there to actually use HA and a the UI. With HASS – 32bit, it also hangs during the installation and cycles through 1 of 5, 2 of 5, etc. and says, “A start job is running for HassOS ZRAM…” and “Wait until kernel time synchronized”. I don’t know if I’m having these problems with the HASSos b/c it doesn’t yet support 8gb on a RPi 4 or if there’s another reason. So it seems that my only option right now is to run HA on Raspian with Docker.

I have spent the last five days combing through every forum that I could find and either there was no answer available or, if there was an answer available, it didn’t explain how I could do it (e.g. editing the configuration file).

I should mention that I have both a zigbee and z-wave plus USB “hubs” that I can plug in to the pi. I haven’t used them yet but ultimately, I’d like to use devices that require either of these. I would also want to use the pi for things like PiHole, PiVPN, and maybe some other things in the future but right now, I really just want to get HA to work.

I’m using HA 0.113.3, Raspberry Pi 4 (8gb), and Docker.

Start with this :

It will allow you to install addons. Once installed, come back for your other questions.

3 Likes

I don’t believe that Wiz lights are natively supported with an integration. I seem to remember reading about a custom component, however I could be wrong.

When searching the integrations page I can’t seem to see ThinkEco. Have you checked to see if it is supported?

The Roborock should work using the Xiaomi Miio integration, found here

The SmartLife plugs will most likely work with the Tuya component. Follow the set up instruction using the Tuya component.

There is a Beta for Home Assistant OS I believe, that supports the Rpi4 8gb available here You’ll want hassos_rpi4-5.0.img.gz.

Thank you so much! This worked perfectly!!

Thank you! I’ll check them out!