Noob advice for conbeeII

Just received a ConbeeII to replace my Xiaomi Aqara hub. I can see the usb stick with lsusb and it shows up as ttyACM0 under /dev (not ttyUSBx)

However it does not get recognised in deCONZ (no device ever shows in the dropdown menu) and HA can’t connect to it either when configuring as ZHA.
I tried to configure it under Integrations, but I get an error message:

Same happens if I manually configure it in configuration.yaml with:

  usb_path: /dev/ttyACM0
  database_path: /config/zigbee.db

I’m using HA 0.93.2 in docker (with - /dev/ttyACM0:/dev/ttyACM0 listed under devices in my docker-compose of course)
Not really sure what else to try…

That looks like ZHA not deCONZ config, have you installed the deCONZ add-on?

Once installed and configured, start the add-on and open web ui to add the devices etc.

Thanks. I’m not on in on a regular docker on Ubuntu.
Like I said deCONZ is not detecting any device do not too sure how to go now…

According to the ConBee II is compatible (with zigpy) and so you should be able to use the ZHA integration.

I’m waiting for my ConBee II to be delivered today …

Thanks. Do let me know your experience. I’m waiting for an answer back from dresden electroniks.

I’ve just plugged it in and used the ZHA integation. Type DeConz, device:


To get the device name: Plug it in. Run “dmesg” and towards the bottom of the text you should see something like this:

cdc_acm 3-2:1.0: ttyACM0: USB ACM device

You can use /dev/ttyACM0 but that could change, for example if you also have a ZWave dongle.

# ls -l /dev/serial/by-id/
total 0
lrwxrwxrwx 1 root root 13 Jun  6 01:37 usb-0658_0200-if00 -> ../../ttyACM1
lrwxrwxrwx 1 root root 13 Jun 10 11:15 usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE1964957-if00 -> ../../ttyACM0
lrwxrwxrwx 1 root root 13 Jun  6 01:37 usb-Sierra_Wireless__Incorporated_AC318U_354088040158013-if00-port0 -> ../../ttyUSB0
lrwxrwxrwx 1 root root 13 Jun  6 01:37 usb-Sierra_Wireless__Incorporated_AC318U_354088040158013-if01-port0 -> ../../ttyUSB1
lrwxrwxrwx 1 root root 13 Jun  6 01:37 usb-Sierra_Wireless__Incorporated_AC318U_354088040158013-if03-port0 -> ../../ttyUSB2
lrwxrwxrwx 1 root root 13 Jun  6 01:37 usb-Sierra_Wireless__Incorporated_AC318U_354088040158013-if04-port0 -> ../../ttyUSB3

The second device has …/…/ttyACM0 on it which matches what was seen in dmesg.

Turns out I did not RTFM. Once I followed the correct instructions to install deCONZ, I managed to get it running and apply a firmware upgrade.
The plan was to transfer my Xiaomi devices over to deCONZ/ZHA to get away from the Chinese spies.
Turns out I whether I use deCONZ or ZHA, I have the same issue where reported battery level is always 100% whereas via the Aqara Hub I get what appears to be a correct value (41% and 43% for 2 sensors with a 1+ year old battery in them.
I’ll raise a new post for this. The issue raised on this thread is now resolved

@lolouk44, would you mind sharing which part of the manual made it work for you?

Also is this the one:

My Conbee II is working fine on RP3, but I am considering switching to my NUC with Ubuntu/Docker.

I have installed on Ubuntu and then tried the deCONZ addon as well as the proper docker container, but I can’t get the Conbee to show the firmware version - it just shows as “not connected”.
Was it the same for you?

I have added my user to the dialout group.
ls /dev is lists the ttyACM0 device. Same if check within the deconz container, so it seems to be exposed, but it’s not talking to any devices. I also restored my Phoscon GW backup, but no joy.

I am not sure what am I missing.

Hi @Viggen

I can’t remember exactly, I think I installed phoscon following these instructions and then it all started working.
linking to HA or using the container did not work until I installed phoscon (I guess some drivers are included in the phoscon package)
Please note: I’m on Ubuntu, not

Thank you. I think the root cause of my issue was misconfigured Traefik. I reinstalled Ubuntu and managed to get deCONZ working first try.

I am on Ubuntu + Docker CE and (piped into bash) and it seems to be running well.