Noob question: How to get a configuration.yaml addtion to show under "services"?


I am new to HA. Installed it just a few days ago, and have spend quite a bit of time getting confused over it already. Nice to meet you all :slight_smile:

I tried getting it to make calls to an IFTTT webhook because my BroadLink remotes work much better there than with HA. To do so several guides state that I add this to my configuration.yaml, restart my instance and I should be good to go:

    key: cRd*******************

Another guide had an extra level with key:. I tried both, did not work.

I expect my ifttt to show under services in developer tools as stated in this guide: IFTTT - Home Assistant (which is the one I followed)

There is nothing there labeled ifttt. What have I done wrong?

What have you done ? … above shows that you seems to have missed alot, in the docs you’ve been reading, or that you just hold back on this info.
i.e. This i what i gottogoon

Already this is not right. The docs said two spaces indentation , you have 4.

Wow, that was pretty fast. Thanks for getting back :slight_smile:

I went through the steps contained in the guide I linked to earlier. Added the integration with the wizzard, then went to the config file, added the entry and restarted HA. The guide seems pretty self-contained. As the last bit, I’m told to test under developer tools. When I look for ifttt in the dropdown that contains all my services, nothing shows. The guide doesn’t say there is more to be done. Are you saying there are additional steps?

There was a step, saying , Check the log-files :slight_smile: , not that i know it reveals anything, but always a good “First step” in troubleshooting

Well spottet. In my first attempt, I copy pasted it from the guide, so I am pretty sure I’ve tried it with 3 spaces and the 4’th was added as a result of messing around with it all evening yesterday.

It also didn’t fix it. After a restart, the ifttt still does not show in services.

Good point . Not much to go on though:

Full logs

No errors have been reported

(I was only aware of the logbook, which also shows nothing)

I always use /Settings/Systems/Logs , there you can choose, several logs, … or using “file-editor” or “Samba”, where you can view the home-assistan.log

PS: Did this step also turn out well ?

Settings/Systems/Logs is exactly where pressed the “load full logs”-button and copy pasted the above result from. Nothing has been logged, it appears.

Did you try the drop-down up-to the right, and look even the Supervisor.log part ?

There isn’t a dropdown to the right. Here’s what it looks like:

I also went through the entire config folder to see if I could find any log-files. I couldn’t. I use HA on docker on a Synology Nas.

hmmm, that’s weird, but maybe HA-Docker is different, but the full-log should be in /config 3st, “buffer” + .log + .log.1(older)

That is the same guide that I liked to, I believe. I went through the Configuration part, skipped the " RECEIVING EVENTS FROM IFTTT"-part (because that is not what I am after) and did the steps noted under “Sending events to IFTTT”

While writing this, it dawns on me that HA doesn’t seem to care about anything I write in that file. Even syntax errors. I don’t think it is loading my config file at all. I think I need to look at my docker configuration.

But you have set up your HA with external-url ?, as mention under prerequisites

So you don’t know whether ifttt and HA is communicating ? :slight_smile:

No, I did not. It is stated as a prereq to sending from ifttt to HA, and I want it to go the other way.

I found the issue. When installing via docker, you have to point to the config folder. I had trouble installing, so I did it several times. I must have missed that part at some point so whatever changes i made to the .yaml file didn’t matter. That is why there wasn’t anything in the log file. It should be stuffed with errors because I messed with it all evening yesterday. It must have used a different config folder (or none at all, not sure).

Thanks a bunch for helping. I wouldn’t have connected the dots without you.

I’ve pointed to the folder now, and I see a service called ifttt.trigger

Yup, be aware your are still in the cradle, and “confusion” will never stops to be a part of your experience :wink:

Thou i still believe you might wanna “receive” events, unless you have some kind of “local” events to “trigger”

It is really hard to know how you could miss this, as the directions are very clear Linux - Home Assistant

It is also hard to know how you copied and pasted two spaces and got 4.

I don’t want to pick on you in particular. But there many people who promise that they have done everything by the docs, then after 20 or so posts it is revealed that they really didn’t.

I realise you are a newbie, and the phenomena is not unique to you. Glad you managed to sort it.