Nortek HUSBZB-1 Zigbee Intermittent Connection Problem

Hello, I am relatively new to Home Assistant and am having some serious issues with the reliability of my Nortek HUSBZB-1 Zigbee network. I have 36 devices installed between light bulbs and plug sockets. All light bulbs are Sengled E11-N1EA and all plug sockets are Sengled E1C-NB7. Connecting the devices was super simple and so was setting up the dashboard. The issue is that the HA GUI just zonks out every few minutes or so and then nothing works. If I let it sit for a few minutes I can then get a device to toggle or change state, but usually only one device works for a few seconds and then it zonks out again. I’ve tried logging in via the remote interface as well with the same results.
I’ve tried everything short of reflashing the uSD card. I set up several scripts that are supposed to set 10+ devices to a specific state but less than half ever actually do anything when the script is run. Ultimately I can get every device to respond, eventually, but literally nothing is reliable. Any/all help or advice will be extremely appreciated. Thanks!

Core version: core-2021.8.8
Supervisor version: supervisor-2021.06.8
Host version: Home Assistant OS 6.2
RPi4 8Gb/32Gb

None of the Sengled devices are Zigbee repeaters. I’d recommend adding some other Zigbee outlets, like those from Cetralite, Innr, or IKEA, to help create a strong Zigbee mesh network.

Thank you for the reply! I read in several places that the sockets (plugs) are repeaters. This seems to be supported by the device map in HA. I grabbed a screen shot of the visualization map. The ellipses circled in red are the plugs. The rectangular box close to the center which I’ve circled in blue is my HUSBZB-1 and all of the circles are light bulbs. There seems to be a rather well constructed mesh between my plugs. The plugs are distributed all over the house. Even the plugs suffer from the same intermittent issue that the bulbs also seem to suffer from. It’s almost like the entire GUI loses connection with the RPi4 hardware. It either recovers between 2 and 30 seconds or just never executes the desired command. You can turn a device on and physically observe it turn on, then try and turn it off within 5 seconds of turning it on and it zonks out on me. See picture attached for zigbee visualization map:

Interesting…:thinking: Your Zigbee map definitely does appear to show them to be repeating.

When Sengled first released the smart plugs, I recall many users asking whether or not they were repeaters. Most seemed to find that they were not, and even Sengled seemed to indicate as much in this Amazon Question and Answer…

This is for the Sengled E1C-NB6…. That must be the difference.

Looks like that particular model is indeed a Zigbee repeater! Nice!

1 Like

Is your stick attached directly to your rpi? If so, I would highly recommend you “create some space” with a USB extender. It can be a very short one, as long as the stick isn’t connected directly to the USB ports.

USB 3.0 ports generate potential interference with any radio based USB devices.

1 Like

I will definitely try that tonight! Thank you. It almost seems like there is a buildup of too many commands and that not all of them are propagating into the mesh. I don’t know why but it just feels like data collisions of some sort.

I’ve seen suggestions of changing zigbee and 2.4GHz wifi channels to better clear their respective lanes, but this doesn’t seem like just a laggy network. This seems like an actual problem. Unfortunately I am ignorant as to its troubleshooting process due to lack of experience with the interface and OS.

That is a good suggestions but before going down that road, it’s best to start with the simplest steps first. If your USB stick is directly attached. .trust me…that is the first thing you want to fix as it will definitely cause reliability issues.
If that doesn’t immediately resolve your problem then the next step would be a mesh rebuild. Simply shut down your pi for at least 20 minutes. Detach the nortek stick as well to ensure it doesnt receive power from the USB port.That would put your zigbee devices in “panic” mode. Once you reattach the nortek and turn your pi back on, your mesh will slowly rebuild itself. Give it time to settle and hopefully you are good to go.

1 Like

I bought a 6ft USB extension cable from Walmart last night and installed it immediately when I got home. It seemed to help a little bit, but it definitely wasn’t the “miracle cure” that resolved everything. When I ran our bed time routine last night only three devices changed state. There should have been 12.

Your suggestion about the mesh rebuild is interesting. I had set up a programming station by my computer when I installed all of these bulbs and plugs over the weekend. I had all wifi connected devices and in one fell swoop bought enough Sengled devices to replace 90% of my network. Coupled with that I have also recently upgraded our home wifi network to a mesh Orbi system by Netgear. Anyway, I would install three bulbs into the light fixture of the fan in my computer room, connect them, name them and then remove them from the fan and install them in their permanent home sockets. I did the same thing with the plugs which are the repeaters. My computer desk has two large power strips built into it, so I just filled up each of the sockets with a plug, connected them, named them and then removed them and installed them into their permanent homes as well. Are you essentially saying that since they “built” the mesh network while they were all sitting right next to each other (literally 4 inches away) that they might have built an inefficient mesh? I will definitely try resetting the mesh tonight! Thank you for the suggestion!

I made sure that the USB extension/Nortek stick were plugged into one of the USB 2.0 ports on the RPi4. Resetting the mesh seemed to have helped, but did not resolve the issue. The mesh did reform and does appear to be more stable. See the attached picture of the new network. The single device control seems to be a bit more reliable, but it the entire GUI still seems to zonk out for a bit where you can still try to toggle a device, the switch moves, everything freezes for 1 to 10 seconds and then everything starts to respond again. Also, the nightly command that I just ran which used to shut off all of the lights in our house (usually around 10-12) left six still on. I manually shut them off and they did respond that way, but halfway through the interface zonked out again. Are there logs that I can check to see if something is maybe loading down the HA server or something? HTOP didn’t show any excessive memory or CPU usage so I don’t suspect that the RPi4’s hardware is being taxed.

Unfortunately this definitely did not resolve the issue. Single device control seems to have improved, but any scripts/automations leave out entire devices to toggle. Also, routines setup in Alexa are a 50/50 probability that they’re going to work. I picked up an SSD tonight to load everything on. Hopefully that gets it going a bit better. The uSD card in the RPi4 is fairly old and most likely not rated for high read/write cycles.

I remember seeing somewhere that there was a way to do an energy scan with bellows (used by the Nortek zigbee chip) but it wasn’t a straightforward process. I had reliability issues when I moved from my Conbee2 to one of @tube0013 zigbee coordinators and the energy scan revealed congestion on channel 15 (zha’s default). I moved to 25 and things settled down nicely for me. If your ssd experiment doesn’t improve things You, you might want to try the HA discord and ask for help with bellows related tests. That’s where I go when I need any advanced help.

Edit: it was actually on tube’s thread that I saw the bellows scan info. See this post:

I reset everything in my network and reconnected every device on my network. I read that zigbee devices have built in “neighbor tables” that they write to when they join your network. These neighbor tables are what are used to dynamically calculate the best path for each signal. I had a “programming station” setup where I programmed all of my plugs into a long power strip, assigned each one, then carried them to their permanent home. That’s a BIG no no. Their neighbor tables were all screwed up because they joined the network all right next to each other and right next to the zigbee adapter on the RPi4. Resetting them resets their neighbor tables. I left the RPi4 in its permanent home as well and reconnected each plug first so they could build their repeater mesh. Once that was done I reconnected each end device to the network from its respective permanent home. The result is the picture below. It’s much more stable than before. I’m starting to think that there’s something not quite set correctly with my config but I have absolutely no idea where to start. It’s just like it goes to sleep or the devices go to sleep or I don’t know. It’s just randomly locking up, but so does the UI. I might have fixed a problem that I didn’t know that I had but I’m pretty sure that the major issue is still at large. When it’s responsive I can toggle lights repeatedly and very quickly. Then it will just lock up for a few seconds. No light toggling and no toggle switch animation in the UI. Then it becomes responsive after a few seconds again.

FYI, I submitted this general troubleshooting guide for improving Zigbee network range (and stability):

As well as a related guide for best practices for avoiding pairing difficulties (inc. tip on pairing location):

Also suggest that you consider upgrading the firmware on your Zigbee coordinator if you not done it yet:

PS: Note that HUSBZB-1 uses an obsolete hardware chip so maybe consider buying a newer dongle.