Norwegian TTS and decimal numbers


Not a major issue, but I’m trying to build an automation with TTS that will tell me the current temperature outside.
I’ve successfully made this, but my problem is that I use Google TTS with Norwegian language, and we split our numbers with comma instead of dot (10,4 instead of 10.4), and this makes the TTS sound wierd. Is there any way I can have selected numbers stored in HA with dot changed to comma values?

Hello from Sweden, I had the same issue and fixed it with a template sensor replacing the comma for a dot.

  - platform: template
        value_template: "{{ states('sensor.27_temperature')|replace(',', '.') }}"

In the script I use for TTS I use “sensor.utetempswedish” instead of “sensor.27_temperature”.

(For completeness:) in scripts.yaml

  alias: Tell me temp
    - service: media_player.volume_set
        entity_id: media_player.kok
        volume_level: 0.8
    - service: tts.google_say
        entity_id: media_player.kok
        language: sv
        message: >
          Temperaturen utomhus är {{states ('sensor.utetempswedish') }} grader.

I’m hoping that someone on this thread might be able to help me with my TTS problem also. Rather than creating a new thread, I thought I’d ask here first.

I have 2 scripts that I run daily via Alexa. The first is “time_for_bed” and the second is “good_morning”. Apart from manipulating the lights and switches in my home, the scripts play a TTS message through Android TV connected to my main floor television.

Below is the text that should have been spoken today…

Preparing the house for bedtime. Good night Tom. Cody is at home (since 17:24) and Cheryl is at home (since 19:07). The weather is currently Clear. Tonight will be A mostly clear sky. Low -2C. Winds light and variable.

Good morning Tom. Today is Monday. Cody is at School (since 08:14). Cheryl is at Longo’s, shop, supermarket, Main Street (since 11:41). Todays weather is Partly cloudy, continuing until tomorrow afternoon. It is currently 21.2 degrees inside and 1.3 degrees outside but it feels like -3.4.

The problems I’m having:

  • in the first one, the TTS speech ignores the minus sign and just says “Low 2C”
  • in the second one, the TTS speech treats the “.” in the temperatures as if it is the end of a sentence and just pauses instead of saying “point” or “decimal”. Surprisingly, it does not ignore the minus sign in the “-3.4” and speaks it properly.

What is the best way to deal with these mispronunciations? Some of the data comes from discrete sensors, but some of it is part of the weather forecast from DarkSky and/or Weather Underground.

(currently running HA version 0.59.2)

Hello. I’m a beginner. I can not get the temperature of a sensor (from Vera). If I do a test hereimage
it reads my test completely. The name of the sensor I got from here image.
What do I have to do, do I have to activate other functions? I do not understand where “date_template:” should appear.