Not able to add Withings integration using Nabu Casa

I am having an issue with adding the Withings integration using nabu casa. This is the first time I am using nabu casa to link an integration.

When trying to add the integration to Home Assistant I am receiving the following error message:

Aborted. No URL available.

I am using Home Assistant 2021.4.6 (OS 5.13).

Extract of my configuration.yaml


I followed the instructions and made a Withings dev account. I have followed the setup instructions in the withings integration documentation:

So far I have tried:

  • Checked my call back URL in my browser.
  • Double checked both client ID and client secret.
  • Tried with and without use_webhook: true
  • Double checked my Nabu casa url and made sure the callback url it is in alignment with the setup instructions.
  • Different browsers (Edge, Firefox, Opera) all lead to the same error.
  • As decribed here I have tried adding the integration using the remote UI url, through local homeassistant url as well as using the local IP. But all tries result in the same error message.

Any help would be greatly appreciated.

After 2021.3 it still worked with a bit of finagling, but as of 2021.4 I think Withings is completely broken. I haven’t seen anyone that’s been able to get it working.

Does any one have an update on a fix for this as I’ve had this issue for a little while now with no apparent options for a fix.