Not able to connect ConbeeII to ZHA

I try to connect my ConbeeII dongle to ZHA.
I’m not able to get it running.
I do run HA supervised as a VM under Unraid.

If I do select the conbeeII to add to the VM.
image

and set up ZHA it is recognizing the conbeeII.
image

(It is showing as choice) after selecting it runs for a while and coming with a menu to select radio type.
I select Deconz.
image

After that I do have to add manually the path. At the and is not starting ZHA because it can not connect to the ConbeeII
image

image

After that I did install USB manager in Unraid and selected the Conbee to connect only serial.
Now I’m able to start ZHA .
But after starting and go to the radio entity it says:
image

image
The device is switched off by integration.

Any ideas how to integrate the ConbeeII to ZHA in HA VM?

I’m not aware of USB/serial Passthrough in QEMU, however the deCONZ Stick does not use a standard serial interface (which is basically UART). For z2m, I use, you need to tell it that it need to talk to the stick using the deCONZ way.
To be precise, it uses a ttyACM which in the linux world is a modem interface while serial in linux (ttyUSB/ttyS<n>) mostly UART.

For Z2M see “Other” categorie here.
For ZHA the documentation (here) also specifies a radio type deconz, it might work if you configure it manually but may you need proper usb or atleast the proper ttyACM modem as a passthrough.

So ZHA need some configuration for that too. If the (usb) stick is detected this could be autoconfigurated. But as your seventh screenshot shows there is a QEMU Serial detected may confusing the autoconfiguration mechanism or it might even not be capable of what an ACM could. Further, USB does provide more information about vendor, product and more then a plain serial/modem provide. But exectly these informations are widely used for autoconfiguration.

The easierst way would be to pass the usb as a hole through and HA OS can do its magic :slight_smile:

Thanks for the answer.
It explains a lot.

But I still don’t know how to connect :slightly_smiling_face:

You have configured USB Passthrough in UnRaid? What do you see in Configuration → System → Hardware → All Hardware (Don’t know how its translated correctly, u can find it in the dots menu at the top right)?

You shall see something like this:
Bildschirmfoto_2023-01-25_13-51-00

If so, what does device discovery tell you? A ConBee should be discovered, if so you can add the ZHA integration and follow the configuration steps. You might need to restart the VM for HAOS to discover the device properly.

Thanks for your reply.
I try to find your screenshot on my Unraid.
I think i’m stupid but I am not able to find that.
I do not see something like configuration?

This is my menu?
Do you mean settings?

If you mean with USB passthroug selecting the USB in the VM I do:

My screenshot is from HAOS, for UnRaid I can’t help. I can’t find documentation on Passthrough configuration for UnRaid, but in your initial post it seemed you have figured it out.

Your second screenshot looks promising, what does HAOS tell you? Maybe after restarting the VM.

AHA oke now I understand.
I do see this:

If I do start tto install he ZHA integration. It is showing my conbee see picture above in my first message.
But it is not recognizing it as Deconz

It is recognised as QEMU Serial? Could you restart HA, you device listed in the screenshot looks just right. It could be autoconfigured - as it was done when I tested ZHA.

Thanks again for your answer.
I did restart several times.
Restart the VM
restart from HA itself.

All the time the conbee is showing up and in hardware overview and in ZHA integration setup:
image

But it is not recognizing the conbee

So HA does autodiscover it, and it should suggest to install deCONZ integration for it?

Have you tried if deCONZ integration works?

I’m coming from a Deconz Docker under Unraid. There the stick is just working fine
I did also use the Deconz addon in the past. That did work also fine

Hmm… if deCONZ (HA addon!) was able to recognize the stick as per your current configuration in unraid ZHA should be able to.

Then I’m sorry I lag any ideas what you could do further.

No problem.
Thanks again for your help. I do appreciate that.
I do already have Z2M as Zigbee radio with a Sonoff dongle.
But I like to have an extra network
So it is less important as having no Zigbee at all