Not able to get Xiaomi Gateway Key

xiaomi
Tags: #<Tag:0x00007f1b9848a430>

#22

I tried on Android device and hacket MiHome app but for Aqara gateway app show only network token and mac address.

This is the main problem becouse option “About” under Device’s context menu is missing :frowning:

As you can see in this picture option “About” is missing:

and if I open General settings there is still same no option “About” :frowning:


#23

I have the About option in v5.4.1 if that helps.


#24

Unfortunately Aqara Gateway doesn’t work with older version then v5.4.19 :frowning:

So I try find another way how to show password then MiHome app. Do you know anyone another way how to find out password?


#25

Following this. After retrieving the token Ihoped it could be used to fet the passkey some way but am stuck in the dark…


#26

To retrieve the tokens of my Mi/Aqara hub (camera hub), i followed New Xiaomi aqara camera/gateway with success. I got 2 tokens, one for each device, a 32 character hex string (so 2*16).


#27

Hl.
Reading your post it seems that there’s a way to get a key starting from token. You say 2*16.
I have extracted a token from file miio2.db. it is 32 bytes. I need a 16 byte key for inserting into configuration.yaml.
Can anybody help me please?
Thank you.


#28

Well, not sure whether it is going to work, but when you take the 32 byte hex code (the post in New Xiaomi aqara camera/gateway for instance there is a token mentioned of “473055577175774b4369774835553044”) and convert that in https://www.rapidtables.com/convert/number/hex-to-ascii.html, i get “G0UWquwKCiwH5U0D”, a code of length 16.


#29

I have the same issue. Convert the Hex to ASCII and till now no luck.
Error: “Setup failed for xiaomi_aqara: Component failed to initialize”


#30

Thanks Raoul, I will try conversion of the token.
An give you feedback.
Ciao


#31

Ciao,
I have tried conversion. I got a 16 byte key but it does’n work.
:frowning_face:


#32

Ciao Giorgio, novità? anche io non riesco a recuperare il token.
Se installassi una versione precedene di Mi Home su un altro cellulare e poi condividessi il gateway con questo potrebbe funzionare?


#33

Hi,
unfortunately i have no news.
I have an Aqara Hub that is connected to Mi Home App on android device.
Al works fine but on the recent versions there is not the menu voice “About” for getting the password.
Following some tutorial i have extracted the database Miio2.db from application and got the token (32 Byte).
Unfortunately i’ m not able to convert into a 16 byte key, if it is possible.

I have tried to install also old app versions but it seem they are not compatible with Aqara Hub v3. So i was unable to connect it.

So, at the moment my Hub is not connected to HA platform. And also other devices i have bought (Temperature, motion detection, ecc) are useless !

Ciao.


#34

Try change language in English. I solved!!!


#35

What do you mean with change language to English ?
My app is already in English. Version 5.4.43 but no “About” menù choice.
Ciao.


#36

The about menu should be accessible on the gateway screen, click the 3 dots top right


#37

Yes this is true for app old versions.
But not for the last ones.
Unfortunately the old version don’t connect to Aqara hub V3.


#38

My app is version 5.4.50 and has about screen


#39

Interesting. My app is 5.4.43 and don’t have.
App say that is up to date.
Do you get 5.4.50 on playstore ?
Ciao.


#40

I have found and loaded version 5.4.50 but still unable to find About voice.
Can anybody help please?
Thanks.


#41

Do you not have this screen ?